DodgeTalk Forum banner
Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Well I took the battery of my 2003 Ram 1500 4.7 L truck and now my truck turns of on me when I am at a stop or slowing down. Instead of the motor maintain idle it shuts off. My warranty just expired. I called the dealer,they told me that I will have to place it on the computer and the cost is $75 and additional costs from there. It looks like i have to get ready for the shaft. :grum: HAs anyone had this problem? Or suggestions


:help:
 

·
Registered
Joined
·
23,005 Posts
So did you buy a new battery? I heard these trucks run like crap without a good battery, not like other vehicles that run okay once they get started and going.

KB
 

·
Registered
Joined
·
30 Posts
Did you try to remove the battery cable for 15-20 mins and then reconnect? It will reset the pcm.
Also, check and make sure there are no vacuum lines off. It will do the same thing.
 

·
Registered
Joined
·
2,035 Posts
KB112 said:
So did you buy a new battery? I heard these trucks run like crap without a good battery, not like other vehicles that run okay once they get started and going.

KB
That is very true. On my old 99 5.2L Ram I had a bad
battery and needed to be jumped started. Once it
strated that lights would be very dim and strobe flash.
The truck barely ran. Once I installed the new battery
it ran like a champ.
 

·
Registered
Joined
·
183 Posts
How long has this been going on? My Jeep had a dead battery and had to be jumped. On the 30 mile commute home it ran like crap. Once I got home, shut it off and started it back up it was fine. My theory is that the computer had forgotten how to run the motor and took a bit of time to relearn it.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #7 ·
I had taken the battery off before, and the same misfire had happened but the computer adjusted itself and the truck ran perfect after using the truck for a couple of hours. Now the computer does not seem to adjust itself.

I will try using a battery of another truck to see if the battery might be the problem. I will also check for a loose vacuum line. Thanks Guys!!!!! :ylsuper:
 

·
C HEMI GO
Joined
·
1,739 Posts
Maybe I'm misreading. Are you trying to drive without a battery?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #10 ·
No, I placed my battery back on the truck and it was shutting off when i tried to stop or turn. I guess the computer was reset. I used the truck right now and it is running fine. I guess it took 3 days of driving for the computer to program itself. I am so relieved.
 

·
Drug Dealer
Joined
·
666 Posts
The same crazy $hit happened to me about a month ago. My battery died, I jumped it and drove to Autozone. I bought a new battery put it in, drove home and it died as I was pulling into the driveway. I started it back up and it was idleling erratically. I drove it for a couple of day and it never got better. It continued to die on me just like you're talking about. I took it to the dealership and left it with them. They replaced the Idle Air Control motor and it's pretty much fixed. If I'm sitting still and pump the gas a few times, sometimes it will start jumping from 400 to 1000 RPM's. The only way to stop it is to turn it off then back on.
I cleaned the throttle body and I'm about to put new pugs in to see if it helps any. I have no idea how one thing relates to the other but it did help. Maybe somehow it caused a short or something. Anyway the IAC motor was the solution to my problem. PLEASE let me know what you find out.
 

·
Registered
Joined
·
48 Posts
That story had everything....comedy, drama, mystery, suspense and a happy ending.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #14 ·
In my case the computer just needed to program itself. The truck is running like a champ, it has not turned off on me anymore. The truck idle works normal now. I am just glad that i did not have to take it to the dealer.:nutkick:
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top