DodgeTalk Forum banner

Status
Not open for further replies.
1 - 20 of 75 Posts

·
Registered
Joined
·
28,800 Posts
Discussion Starter #1
Guys, my lights are all screwed up, and the dealership is trying to really screw me over on this. Let me tell you how it started...

First, I am driving down the highway, and some guy honks and says that my brakelights arent working. I dont have a lamp out light, but sure enough they dont work...BUT, the 3rd brakelight does work. So does every other light on the truck (headlights, foglights, front and rear turn signals and driving lights, etc)

So I take it to the dealer this morning, and they tell me that the original owner added an aftermarket 5 pin trailer harness that was installed poorly, and that it caused a short in the tails. Because it was not a factory part, they would not warranty it, and charged me $300 for the labor to diagnose and "fix" the problem...By fix I mean remove the 5 pin harness and res solder all the wires that were cut.

So I go to pick it up after I got off work, and now when you turn the headlights on, the rear driving lights and 3rd brakelight turn on. Then, the front driving lights (corner lamps) come on every time you apply the brake even if the lights are off. The tails dont work and the 3rd brakelight stays on as long as you have the headlights on. With the headlights off, the rear tails and 3rd brakelight seem to work fine.

What the hell is going on here???

I am going to the dealer 1st thing in the morning to speak to the service manager. If he wont help, then I will go to the owner of the dealer, and up if I have to. I want the truck fixed, and I want my money back for their poor work and for wasting my time. I was suposed to work tomorrow, and now I am not going to risk driving over an hour to work with no taillights.

Can anyone give me some help here? Any ideas what might be causing this?
 

·
Registered
Joined
·
31,160 Posts
I don't know whats going on, but damn thats stupid.

Did you buy it from these guys? If so, they sold it to you this way - they should care for it! Not your fault that someone added something to it and they didn't catch it when they did their inspection on it upon obtaining the truck.

Good luck Matt.
 

·
Registered
Joined
·
231 Posts
sounds like a bad ground. Can you run a temp ground to the rear lights, go from the - side of the battery, run it tight to the tail light, either side. make sure its the ground. tap into the wire and retest.
 

·
Registered
Joined
·
1,748 Posts
If you paid to get it fixed, it should be fixed right?
If you bought it from them than they should warranty it.
Cancel payment and tell them to eat it
 

·
Registered
Joined
·
28,800 Posts
Discussion Starter #6
I bought it from a different dealer that is over an hour from my house, and I dont want to drive an hour with no tails. I am not going to touch their wiring, so that they dont try to put any more blame on me. I am just going to take it up with the service manager tomorrow and hope for the best.
 

·
Serenity
Joined
·
5,947 Posts
Well I was close in that original post that the trailer harness might have been involved. You can try to disconnect connector C134 and C135 as shown in post #13 of the original thread below to see if that makes any difference:

http://www.dodgetalk.com/forums/showthread.php?t=240619

You might get a lamp out, but if the front lights work better, you at least know what area of the harness is messed up
 

·
Registered
Joined
·
759 Posts
Go over there first thing in the morning for sure. Tell them they know what this truck went in for and what the problems are now. Thats a bunch of bs bro and Id take it in and make them fix it, they screwed it up and its their fault this is happening. sounds like they shorted out the turn signal switch, thats the only thing I can think of that would have all those controls going through them. So go RAISE SOME HELL!
 

·
Registered
Joined
·
28,800 Posts
Discussion Starter #11
I just wanted to get some opinions to see if something similar has happened to anyone else. I have a feeling they crossed 2 wires. Why else would my 3rd brake light be on with the regular driving lights, and why would my front corner lamps light up every time I touch the brake even when my lights are off?
 

·
6.1 FTW
Joined
·
2,307 Posts
So why are you telling us? You have a plan. do it in the morning. They should fix it for you since you've already paid. Enough said.
Woah dude that's a little harsh. Matt has helped many guys on this forum and has every right to throw this out there for some opinions. The thread could also help other people that might have similar problems in the future.

Hope you get it resolved Matt.
 

·
SAILORwithaHEMI
Joined
·
2,283 Posts
I'm not sure what would really cause it in the first place, but they had to have crossed wired them when they resoldered them like you said. Just don't take no for an answer and call them out on any BS. I am sure you will get this taken care of. Good luck Matt. Oh, and it's not like they can't charge the other dealership for warranty work done on a vehicle they sold.
 

·
OFFICIAL CHEBBY HATER
Joined
·
1,389 Posts
First off it sounded like the brake signal fuse was blown for the left and right side. Im not sure if you checked those first but I know when none of my tails worked that was the reason. Lastly, they fugged up some wires and should fix the problems.
 

·
Registered
Joined
·
28,800 Posts
Discussion Starter #15
I checked all the fuses first, and they were good. Bulbs were good, and I also unplugged my gauges, and the additional reverse lamps I installed, and none of that fixed the problem.

The dealership opens at 8, so I wil be leaving in a few minutes.
 

·
Registered
Joined
·
28,800 Posts
Discussion Starter #16
Well I was close in that original post that the trailer harness might have been involved. You can try to disconnect connector C134 and C135 as shown in post #13 of the original thread below to see if that makes any difference:

http://www.dodgetalk.com/forums/showthread.php?t=240619

You might get a lamp out, but if the front lights work better, you at least know what area of the harness is messed up
Gary, thanks for all your help in this. I know it took some time to do the reasearch you did to figure out what was going on, and I appreciate it.
 

·
I RECOMMEND FUKKEN WAX
Joined
·
13,990 Posts
Let us know how it turns out!
 

·
Senór Member
Joined
·
17,169 Posts
i agree that it sounds like they crossed the park lamp wire w/ the brake lite wire, so the park lamps function as the brake lites now, that's all i got:dunno:


let us know how it goes, and don't let em tell ya that it's yer fault;D
 

·
Registered
Joined
·
837 Posts
Good luck
 
1 - 20 of 75 Posts
Status
Not open for further replies.
Top