DodgeTalk Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have an error code. (P0406 Exhaust Gas Recirculation Sensor A Circuit High)
Does anyone know where I can find it, how to replace it and how much it will cost?

Also, I have an electrical problem with my lights. It seems as if it is only my lights. As I drive my head lights and dash lights flickers.The reason I think it is only my lights is because the engine does not miss fire or anything when the lights flicker. My car runs fine. Does anyone know what it could be? It seems to be getting worse. Also, could this have caused my P0406 error code?

:help:
 

·
Registered
Joined
·
23 Posts
I have a 06 Charger which at one time showed a code for the exhaust. All I did seeing that its not a major engine code was to reset it and see if it comes back. Likely it will not. As for your lighting problem I would say you have a connection problem. start by making sure that all connecters are properly put together. It may be some where in the engine compartment, at the fuse box (front and the one in the rear) or under the dash.

Hope this helps.
 

·
Registered
Joined
·
23 Posts
What I have is a Superchip programmer for my car(plus lots of other mods) and it can read the DTCs as well as reset them. If you get one for your car you will like it. It makes a difference on performance.

Let me know what happens, I'll try and help you the best that I can.
 

·
Registered
Joined
·
178 Posts
flickering lites

Had the same problem with my 05 magnum.took it back in and there was tsb for it.
Now have a head scratching problem, car seems to be loosing coolant. There are no visable signs of leakage,has been preasure tested and there is no engine codes showing up. Any ideas? :)B
 

·
Registered
Joined
·
178 Posts
Antifreeze Disappearing

This problem I have is with 3.5 Magnum. No visable signs of leaking,preasure test, no engine codes. Top it up to Max Line 1500 mi. it's at the Low line or just below. Nothing coming out anywhere,was thinking of a intake leak but you think that foul the plugs or something. This has all started since Dec. car has about 90,000 mi. on it. :)B
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top