DodgeTalk Forum banner

1 - 1 of 1 Posts

·
Word to your Mother!
Joined
·
316 Posts
Discussion Starter #1 (Edited)
2005 Dodge Durango SLT

And here we go......I was throwing a CEL light for the past couple days that would be intermittent, as in, it would turn on, then after a couple of drives without the computer detecting anything, it would shut off only to return a couple starts after that.

I went to Autozone and pulled a P0406 or Po406 (I listed both to help those who search) which is showing a faulty EGR valve, so I decided instead of spending the $70 at the dealership for a new one, I would try to clean up the throttle body and EGR valve before purchasing the new one.....here is my 'how-to':

First, remove the plastic breather hose from the airbox



heres the other side:



After that, you need to loosen the clamps that are around the intake box and the one up by the throttle body cover:





Then, pop off the three tabs around that hold the top of the filter box down.......you can see my finger on one of them.....



Then, remove the two 13mm bolts that hod the lower part of the intake box in place.....



Remove the top of the intake box along with the hose that goes to the TB cover.......



Here's what you should have taken off:



Then, pull out the lower part of the air box.......one everything above is removed, the box is just suspended there by a small grommet.....just pry straight up and it'll come out



Next, remove the intake temperature sensor by pushing slightly with a flat head screwdriver...



Then, remove the throttle body cover by loosening two 10mm bolts. These bolt WILL NOT come out completely as they are attached to the cover itself.....they are shown here



and here



Here it is as its being removed...



And there's the filthy S.O.B.



Here is what should be removed as of now.........



Closer pic on the TB......notice that there are four (4) 8mm bolts that we are going to remove shortly that are pretty straight forward, but there is a sensor plug that we need to remove first:



Slide back the tab and use the flat head again to remove this plug



I followed someone else thoughts on this and shoved a terry cloth in the TB so that nothing could get down there while I removed it.....



Heres what's left after taking off...



another....



Oh SNAP!!!!!!!!!!!



Let's throw some safety glasses on and get at this thing with some cleaner......



AND THAT'S WHEN THE CAMERA DIED............

But at least I get the remove completed.

Literally, 2 cans of BRAKE CLEANER.....not Carb cleaner. Most of the gunk came off just by spraying, but then I used a toothbrush to scrub and scrub and got it cleaned up pretty good.

Once all was send and done and finally dried up, reverse the steps above and you are good to go.

I did get a couple pics of the EGR valve before the camera died.....





To remove it and clean/replace it, just remove the two (2) 8mm bolts that are brass/gold to free it from the brass hose.

After that, there are two (2) 10mm bolts that attach the EGR valve to the passenger side bank. Once I had that off, I sprayed it out with CARB cleaner, not brake cleaner and then let dry for 10 minutes.

Whipped her back together and fired my baby up.........it choked at the first crank, but idled without problems. Ran it down to the liquor store to get a case of beer to celebrate the victory of no more CEL!!!!!!!!!:rck::rck::rck::rck::rck: :cheerl::cheerl::cheerl:

Any questions, I'll be around.
 
1 - 1 of 1 Posts
Top