DodgeTalk Forum banner

21 - 25 of 25 Posts

·
Registered
Joined
·
35 Posts
My problems was stalling when warming up. It would start fine. Run fine but when I was coming up to a stop sign it would just die. It would start up again but die again. This fixed it up just fine.
 

·
Seating for 12
Joined
·
1,893 Posts
Discussion Starter #22
Psyclone said:
My problems was stalling when warming up. It would start fine. Run fine but when I was coming up to a stop sign it would just die. It would start up again but die again. This fixed it up just fine.
I'm glad that the this fix was easy to do and didn't require the dealer to do it.

If you liked this step-by-step how to, please read some of the other helpful stickies on this forum too. ;)
 

·
Registered
Joined
·
35 Posts
Dennis D said:
Stev, Do all TBI's have a IAC valve??? I have a 1990 Power Ram, 318, (5.2?) with a Holley TBI.
You have a different set up. You have and Idle Speed Control Actuator instead of the IAC.
 

·
Registered
Joined
·
38 Posts
Tried the IAC clean, and it didn't get rid of the p0505 code. Then did a complete tune-up (spark plugs, wires, rotor, cap), still got the code. Then, I finally bit the bullet and installed a new IAC. Still getting the code. The only thing that has changed is that the light only comes on sometimes now. I can't figure out what is causing it, because it happens when it is code or warm. When it does come on, I notice a marked sluggishness in the engine and rough idling. Does anyone have suggestions?

Take Care, Sharon
 

·
Seating for 12
Joined
·
1,893 Posts
Discussion Starter #25
lanesharon said:
Tried the IAC clean, and it didn't get rid of the p0505 code. Then did a complete tune-up (spark plugs, wires, rotor, cap), still got the code. Then, I finally bit the bullet and installed a new IAC. Still getting the code. The only thing that has changed is that the light only comes on sometimes now. I can't figure out what is causing it, because it happens when it is code or warm. When it does come on, I notice a marked sluggishness in the engine and rough idling. Does anyone have suggestions?

Take Care, Sharon
Sharon,

Did you also clean that little slot opening at the base inside the TB IAC location. It's just under the IAC port hole. Be very careful with any cotton swab cleaning in that slot. You don't need the swap head to break off! Clean with a light touch and use many swabs soaked in the carb/injector cleaner solution until it's really clean.

Peace!

Stev
 
21 - 25 of 25 Posts
Top