DodgeTalk Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 1997 CTD with just over 150K. It has been flawless for me until the other day. I filled up, drove 25 miles on the highway, exited, and then it died. It would only restart when I pumped the pedal, and the next morning not at all. From what I read in this forum it seems either the lift pump or the injection pump is gone. Where can I get an appropriate set of guages to measure fuel pressure out of the lift pump, and where does the guage attach. Any feedback much appreciated, sure hope it is not the injector pump.
 

· Registered
Joined
·
171 Posts
I would be very supprised if either is bad. It sounds like you got bad fuel. Change your fuel filter. Dump it into a glass container. If you see little flecks of what looks like coffee grounds. You have alge in your fuel. Get some biocide to kill and clean them out.

The P7100 injection pump is the most reliable injection pump out there. The Lift Pump on the 12v engines is a good lift pump as well. There are very few problems with either.

Other problems to look for.....There are 2 rubber lines that run from the frame rail to the engine, they tend to crack and get air into the system. (usually a hard start with the nose of the truck up hill)
People have had problems with the fuel heater gasket/o-ring leaking air. That will take a...I believe 17mm socket to remove the bowl, and inspect. Also check that for debris. It has a screen in it as well.

Josh
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top