DodgeTalk Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Im getting a low pitched squeal when I drive under 10 mph. Its definatly on an rotating part of some kind. Because the faster I go the faster and more repetitive the squeak gets until I hit about 10 mph.

Sounds like something could use some lubing up.....

It sounds like it could be in my rear end but im not sure.

Any ideas?...
 

·
EPA's Worst Nightmare
Joined
·
1,673 Posts
Have you checked your brakes? Could be your brakes or possibly a bearing.
 

·
RoaringRam
Joined
·
408 Posts
Could be your dust bushing or sleeve as the service guys like to call it. I've had a problem with that for a while now and I only hear mine at low speeds. I just recently helped silver_dodgeram with this so I'll post the link to the thread once I track it down.
 

·
RoaringRam
Joined
·
408 Posts
Here is the link to the thread:

http://www.dodgetalk.com/forums/showthread.php?t=60635

I posted some pictures to help him located the squeak. This is at the front end of the truck however, but it sounds exactly what you're describing. If you know it's definitely in the rear end just disregard all of this. Good luck.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
well I guess my truck was built a little differently.... I have a 2000 2wd sport model....but
I did spray wd40 on all the possible places that could be causing the speak ...and one of those worked :p oh well hopefully it wont come back... thanks for the help though guys
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top