DodgeTalk Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

· Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I got my codes pulled a few weeks ago, I misplaced the codes but the dealer still has record of them , i should call them but basically I got a code that said main realay open. Where is the main relay? I looked under the hood fuse box and nothing in there labeled 'main relay'. I also looked at the fuse panel in the cab and same deal there.

I also got a brake switch circuit in the abs module code. Anyone know what that is? Is the the switch right above the brake pedal? My brake lights work fine.

The reason I checked the codes is because my abs and brake dash lights come on every once and a while. The cruise also stopped working around this time. I did some searching and I am about to buy a new 'ouput shaft speed sensor' to try to fix this problem. If that don't work I may try the real wheel speed sensor. After seeing these codes I guess I might want to try buying a new brake switch above the pedal even though my brake lights work.

I drive a 1998 5.9 d-go

Thanks,
Ryan
 

· Registered
Joined
·
5 Posts
I just bought my D and it has the exact same symptoms. The cruise doesn't work at all and the brake/ABS lights turn on and off at random. The dealer told me that they didn't know what was causing the brake dash-light issues, but the cruise control would be fixed by replacing my clockspring. My truck has had several audio and security components installed, so I am curious if somebody created a short when those components were put in under the dash. My ABS works, so I find the lights to be little more than an annoyance personally.

Maybe someone here with a little more knowledge can shed some light on the issues?
 

· Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
My cruise dash light does light up when I turn it on but it just wont set at all. My abs also works. From what I read, i think if the clockspring is bad, the cruise light won't come on. Also the abs/brake dash lights and cruise are probably a related problem.

Check out these useful threads

hmm for some reason it wont let me post URLS check out thread 23609 and thread 10865

Ryan
 

· Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Well yesterday on my way to buy an output shaft sensor from the dealer, I was playing with my brake pedal and found out that my cruise would set for me if I set pressed the pedal down a bit (not enought to trigger the brake lights) . So after this I thought I'd try buying a new brake switch. Well that didn't fix my cruise and I can't set it at all now. I think I'll go to the dealer and try buying the output shaft sensor.

ryan
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top