DodgeTalk Forum banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I am having some problems with my dodge dakota 1997 4x4 club cab. 3.9 L engine. If I floor it, the truck will not shift when it gets to the red line, It will continue to climb as much as i contiue to keep my foot on the gas. But If I let go it shifts down. I have not idea with this but hopefully someone here can help me out.

Chris
 

·
Registered
Joined
·
79 Posts
You mite have seized up kickdown linkage. Look under drivers side of trans, see if it is free. The shifter linkage is at the same spot where the kickdown linkage is.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
I will have a look once I know where it is lol. (Havent done much work on trucks, mostly on a dirt bike which is standard not auto.)
 

·
Registered
Joined
·
201 Posts
maybe invest in a tuner programmer like hypertech.control your rmp when auto shift
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #6 · (Edited)
Okay, I am taking apart my tranmission I will probably replace the soleniod, and governor pressue sensor, is it wise to clean out my valve body? Has anyone done this and how complicated is it.

Chris
ps it will not shift into second gear even when manually shifting into 1st then to second or the other way around etc... So second does not work.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #8 ·
furrycritter said:
Ok, is this only when the pedal is touching the floor, or under normal operating conditions, as well?
Anything over half throttle basically only as long as I let it have too much gas and it needs to be shift down it stays in 1st until it will kick into 3rd. I adjusted the TV cable to not allow so much gas so it shifts sooner with more gas, but a properly adjusted one should be more tens.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #11 ·
Well I have figured out one thing, something is clogged or something is going bad with the cpu, There just is no 2nd gear all the other gears work fine.
 

·
Registered
Joined
·
644 Posts
varsis said:
Well I have figured out one thing, something is clogged or something is going bad with the cpu, There just is no 2nd gear all the other gears work fine.
Might wanna try the TV cable before you tear your tranny apart this is exactly what it sound like to me, do a search for TV adjustment short for "throttle valve"After further reading, realized your missing a gear not shifting too late.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #13 ·
I have tried adjusting the TV cable and When I go onto the hiway it will rev upto 4.5 x1000 rpm then shift to 2 thousand and shift into OD once I get to a speed of about 80km/h so Im not sure, but I don't Think it is anything major, as it just skips it and no METAL
 

·
Registered
Joined
·
48 Posts
Time to have trans rebuilt, just like I just had done.
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top