DodgeTalk Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Dear All,

I have a problem with my 1995 Stratus with 2.5 V6 Transmission (A604).
It started couple of months ago, when occasionally the gear would go into the "limp" mode, stuck in the 2nd gear.

More recently, the problem became constant. And unfortunately, noone can tell me definitely what the problem is.

The servicemen cannot access the Transmission Control Module (TCM) to read the DTCs from it. However, the engine's computer reads the following DTCs:

P: 0500 - No Vehicle Speed Sensor Signal
P: 1695 - No CCD/PCI BUS Message from Body Control Module
P: 1698 - No CCD/J1850 Messages from TCM

The problem is that while the gear is stuck, the speedometer is also not working, the fuel indicator also behaves strangely, as well as other indicators on the panel. The sign PRND3L under the speedometer has squares on all the letters, instead of moving from P to D for example.

If forcing the transmission and putting it manually to L, then the first gear is active, if changing it to 3 the gear would swith to the second, and while putting it to D the gear would switch to the third one, but that's it. It does not go to the fourth one. Moreover, after reaching the speed of about 80 miles per hour with the third gear, all of a sudden the car started to break and went back to the 2nd gear...

What I've been told, there could be 3 major problems:
1) TCM is faulty
2) The Solenoid block on the transmission is damaged
3) The transmission itself needs repairs

Can anyone advise how to proceed?

Understandably, I do not want to perform all 3 operations, especially the last one, which costs about $1200-1400 as I gathered.

Many many thanks in advance and looking forward to your responses!

George
 

·
Capt. Jack Sparrow
Joined
·
1,487 Posts
sadly, amigo, that sounds about right. time for a new tranny.
 

·
FEAR THE 2.5!!!
Joined
·
371 Posts
i also have the 2.5, and the other night my car got stuck in 2nd, but my alternator was dying. not sure if thats your problem. i also have had some problems with my selenoid packs. i'd get them checked, but i replaced one at around $300
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top