DodgeTalk Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
i have a 00 with 5.9l replaced thermostat, antifreeze, and backflushed heater core still get little heat not unless revving up motor top radiator gets hot bottom is cold can take rad cap off after its at operating temp and doesnt seem to have any pressure could water pump be bad truck doesnt overheat though?
 

·
Been HEMIphied
Joined
·
1,933 Posts
Maybe you've got an air pocket in the system.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
how do you get rid of the air? one side of radiator is hot top hose side other sde of radiator is cold low hose side could something be wrong with rad i had rad cap off and didnt notice any circulation?
 

·
Been HEMIphied
Joined
·
1,933 Posts
Well the hot coolant from the engine enters the top of the radiator, and cooler coolant leaves at the bottom of the radiator. If you pull the cap when the engine is cold, and run the engine at idle until it's good and warm, you may start to see the fluid level fluctuate. (You would not necessarily notice any "flow" at the cap opening.) If there's an air pocket, you'll notice some bubbling once the temp warms up. When the thermostat opens, there should be a drop in the coolant level.

Maybe the coolant level is too low. That would render the issues you are having as well.

You may have a bad cap. If pressure does not develop in the system, it won't perform properly. Backflushing could have let some stuff loose and possibly jammed the thermostat open. It's hard to diagnose without being there.

Did the system work fine before?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
it has a new thermostat and fluid is full truck never did blow heat since i have had it for about 2 months could rad be plugged since one side is cold other is hot seems like its a water pump or radiator cant seem to get any air bubbles out anymore
 

·
Previously Micash21
Joined
·
2,802 Posts
what temp thermostat do you have. I dropped from a 195 to a 160 and my temp never leaves 130. I need to go back to 195. If your thermostat temp is low and you outside air is low, you wont get any heat.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
195 thermostat reflushed and got all air out have pressure now but still not alot of heat is there anything that could go wrong with heater switch not opening all the way to hot? coolant is hot but heat coming out is luke warm at idle and warm at throttle nothing hot not like my other rigs i own
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
well still blowing cold air looked under hood and smell antifreeze it was coming out around filler neck when i went to lift it up to lokk it fell in half. has anyone replaced this item before prob dealer only item is it just neck or complete top rad hose assy?
 

·
Registered
Joined
·
4,953 Posts
If you're talking about the plastic fill section (in the middle of two hoses), it comes in one piece.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top