DodgeTalk Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
97 Ram 4x4 Ext Cab 360 V8. I turn the truck on and the headlights work fine, dim and high beam. I put it in gear and the headlights shut off and won't come back on, high beams will work. Instrument panel always stays lit fine. I check all fuses, they are good. What the heck is going on ? I gotta turn the truck off, open the door, and restart it to get the lights on, then they go off again when i drive off.
 

·
Green river boy is here!
Joined
·
118 Posts
Mine does this when the steering wheel is tilted down any at all. If its all the way up it work fine. when its down only the high beams work.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
Not long ago my starter wire came out of the ignition switch from using the tilt wheel alot, maybe another wire did ? i'll keep playin around w/ it. I replaced the headlight switch a year ago thinkin it'd fix a no lights problem i had when it was actually a blown fuse, so it shouldn't be the switch.
 

·
Registered
Joined
·
35 Posts
"Mine does this when the steering wheel is tilted down any at all. If its all the way up it work fine. when its down only the high beams work." Posted by Green RiverBoy

Unreal, my truck has exact same problem as Green RiverBoy !!!!!
Adjust steering wheel anyway but all the way up and headlights go out !!! If any body finds out what the problem is PLEASE POST !!!
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
I drove to work today and as soon as i put it in park the lights came on, put it drive, came off. It's drivin me crazy ! I can't drive at night because of this.
 

·
Bridal Veil Falls
Joined
·
3,229 Posts
Check the linkage to your High Beam switch and also look to see it there are any wires that are loose on the HB switch.
 

·
Registered
Joined
·
80 Posts
I had the exact same problem and replaced the dimmer switch. It's worked perfectly since.

'96 Dodge Ram, 218K miles 5.9L
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #8 ·
I figured out now that the lights are going out when i tilt the wheel up, I wouldn't doubt that the wire is being pulled on since my starter wire came out the ignition switch not long ago. I'll pull the column shroud off when I have time and tinker round with it, I'll post my results, it may be a bit tho.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top