DodgeTalk Forum banner
Status
Not open for further replies.
1 - 17 of 17 Posts

·
Registered
Joined
·
23,005 Posts
I'd rather blow a bulb at 12k than my rear end too early. :D

KB
 

·
Yeehaw!
Joined
·
1,397 Posts
My truck blows taillights and brake lights like it's going out of style. Doesn't really bother me too much because the bulbs are so cheap.
 

·
Registered
Joined
·
2,761 Posts
:thatfunny :thatfunny :thatfunny :thatfunny :thatfunny
 

·
Banned
Joined
·
3,852 Posts
I had one go out at 35k. Now...after I replaced it Im still running in to a problem. My (right side) brake light works but when you turn on the highlights the running light is out. I changed the bulb again....but got the same result........still working it out.....
 

·
Yeehaw!
Joined
·
1,397 Posts
dale3fan3 said:
Are your seals tight? sound like you are getting water in ther or a short
Don't know sir, are you talking about the 0-rings between the actual plastic housing and the piece that holds the 3 bulbs?
 

·
Registered
Joined
·
35,850 Posts
I've never replaced a bulb yet on any of my trucks. (when the ashtray is full I trade it in)
 

·
Registered
Joined
·
25,358 Posts
Discussion Starter · #10 ·
360ciRAM said:
Don't know sir, are you talking about the 0-rings between the actual plastic housing and the piece that holds the 3 bulbs?
Yes thats what Im talking about. You should not be popping bulbs that much. Next time it blows I would take it in to the dealer and have it looked at. Something just dont sound right to me.


*Edit* I see your a 2002 prolly no warranty left. First thing I would check is those seals. IF they leak a little and it rains hot bulbs and water dont mix.
Then have you taped anything into that line that might be causing a line overload?
 

·
Yeehaw!
Joined
·
1,397 Posts
Yea no more warranty left. I will try replacing the O-rings soon, because I get plenty of rain down here in the "Sunshine State"
dale3fan3 said:
Then have you taped anything into that line that might be causing a line overload?
Not sure what you mean by this.
 

·
Registered
Joined
·
10,637 Posts
Also guys... When you replace ONE bulb, its always a good idea to at least replace the opposing one. the draw on the harness from the new bulb will most always cause the older one to blow in short order... Cant explain why, but has ALWAYS been my case.
 

·
Registered
Joined
·
25,358 Posts
Discussion Starter · #13 ·
360ciRAM said:
Yea no more warranty left. I will try replacing the O-rings soon, because I get plenty of rain down here in the "Sunshine State"

Not sure what you mean by this.
tapped. meaning have you added anything to the power source. IE roof lights line of fire etc.
I would try to be sure that those rings arent cracked and dry rotted.


Dane for me I changed all the bulbs except the reverse lights.
 

·
TRICK TURBO
Joined
·
3,865 Posts
and the jap bulbs with the silver housings SUCK!!
 

·
Yeehaw!
Joined
·
1,397 Posts
Ok I will check the rings then, because I haven't added anything auxilary to that power source. Thanks Dale3fan3
 
1 - 17 of 17 Posts
Status
Not open for further replies.
Top