DodgeTalk Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Hello,
I've searched forums for hours and can't find anything about this problem: My boyfriend was driving when the gas pedal went all the way to the floor and we lost acceleration. Pulled over, took the center console out, found that the rod/linkage coming from the gas pedal had just come apart. He rigged it but its happened again.
Sorry I can't use the correct terminology, that's been part of the problem in searching for solutions. He just bought the van and we don't have a manual (yet!) and are learning about vans as we go. It's always something with this one. Any ideas would be appreciated until I can post more specs; its his van van, but I'm the computer literate one.
Thanks!

1980 Dodge 200 van, 1/4 ton, 6 cyl.
 

Attachments

·
Banned
Joined
·
3,120 Posts
A picture of the linkage with a circle or arrow on it to indicate what exactly is coming apart will go a long way in helping us figure out what's happening.
 

·
4 Wheel Power Disc Brakes
Joined
·
5,828 Posts
It sounds like the clamping action has been lost were the acelerator rod arm goes into the engine compartment. This had a flat on it that the arm which is supposed to keep the arm from turning when the pinch bolt is tightened up. Is the arm worn here?
This connection is similar to the transmission shift linkage and kickdown arm on an automatic transmission.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
The female parts sits on a threaded area and is loose. The male part has a nub that is worn. The clamp/pinch bolt is still there, he has tightened it and so far it hasn't turned and become disconnected again. May try to replace that arm at the junkyard. Thanks for your help!
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top