DodgeTalk Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Has anyone had rear light flashing, and front/rear light steady on.I changed both rear ends oil, with royal purple, and cleaned off the magnets and now I get this any one with any ideas?
 

·
Registered
Joined
·
9,006 Posts
Try disconnecting the battery for about 10 minutes. Mine has kept blinking a few times when I KNOW both axles were locked up. Keep us posted.
 

·
Registered
Joined
·
9,006 Posts
Just a thought. I wonder if there is anything in the Royal Purple that could make the electricl connection more difficult ???
 

·
Power Wagon Winch Mob
Joined
·
3,937 Posts
Just a thought. I wonder if there is anything in the Royal Purple that could make the electricl connection more difficult ???
Other than LSD additive?
 

·
Registered
Joined
·
9,006 Posts
Like i said, it's just a thought. But some chemicals are more conductive of electricity than others, IDK ??? Just throwing it out there.
 

·
Power Wagon Winch Mob
Joined
·
3,937 Posts
Like i said, it's just a thought. But some chemicals are more conductive of electricity than others, IDK ??? Just throwing it out there.
I didn't think of electrical connectivity. I haven't used Royal Purple yet, but IIRC reading somewhere, maybe the package itself, there's something else in there.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #8 ·
thanks guys, I'll try the reboot thing and see if that works. I was also wanting to know for sure how many magnets are in each rearend, because when I did all of this maint. I had only one in each rear, and all so noticed that both slid right off, and I could clean them off.I did all of this because of the serv 4x4 light on the dash thing and I also put a new plug on back rear and grease and still no fix,this is driving me crazy:mad and I just put all new carli ball joints under it, and changed over the steering system last weekend also. Ball joints wer a real pain, about 6 hours of fighting the hubs That were frozen solid, but mission acomplished!
 

·
Registered
Joined
·
9,006 Posts
:huh: I did not know they came off. I cleaned mine in place. Maybe they were put back on wrong. Magnets have a + and a -. They will only attract to each other one way, + to -. If you re-installed them + to +, or - to -, they will not attract to each other, & that may make you lights do that if they can't connect. IDK for sure though. :dunno:
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #10 ·
Hey guys, just wanted to let you all know that today i recieved a call from AAM! I talked with a tech. manager about the locker issues I and alot of us have, and he told me the diff. in our trucks are made in (Mexico), but he is going to contact another tech mgr there and try to get to the bottom of our problems, and he told me he is also going to notify someone that there is alot of us that are unhappy with the performance of the product and he is going to check and see if there is any type of replacement waranty available even though the manufacturer waranty has expired.As soon as I here back from him I will post his remarks on here.I sure hope he can get to the bottom of mine and and some of your issues.
 

·
Registered
Joined
·
9,006 Posts
YUP, keep us posted please. If he needs more motivation or just blows you off, post up the phone # so we can all give em a call. :D
 

·
Registered
Joined
·
1,658 Posts
It's good to hear that AAM might be willing to stand by their product and resolve the issues out of manufacture warranty. The only issue I have is that mine are sometimes a little slow to engage.
 

·
Registered
Joined
·
956 Posts
Well I'll keep my fingers crossed...but if there anything like the company's I've worked for.... US ARMY...UNITED AIRLINES, there good at telling you what you want to hear. ;)
 

·
Power Wagon Winch Mob
Joined
·
3,937 Posts
Hey guys, just wanted to let you all know that today i recieved a call from AAM! I talked with a tech. manager about the locker issues I and alot of us have, and he told me the diff. in our trucks are made in (Mexico), but he is going to contact another tech mgr there and try to get to the bottom of our problems, and he told me he is also going to notify someone that there is alot of us that are unhappy with the performance of the product and he is going to check and see if there is any type of replacement waranty available even though the manufacturer waranty has expired.As soon as I here back from him I will post his remarks on here.I sure hope he can get to the bottom of mine and and some of your issues.
That's cool. Nice job! I would definitely be curious what he says. Ask him if you can post his contact info for us. I haven't had any problems yet, but it would be a great resource if and when I do, as well as others.

Thanks!! :)
 

·
..::MOOSE::..
Joined
·
1,580 Posts
Hey guys, just wanted to let you all know that today i recieved a call from AAM! I talked with a tech. manager about the locker issues I and alot of us have, and he told me the diff. in our trucks are made in (Mexico), but he is going to contact another tech mgr there and try to get to the bottom of our problems, and he told me he is also going to notify someone that there is alot of us that are unhappy with the performance of the product and he is going to check and see if there is any type of replacement waranty available even though the manufacturer waranty has expired.As soon as I here back from him I will post his remarks on here.I sure hope he can get to the bottom of mine and and some of your issues.
:tup::tup::popcorn:
 
1 - 15 of 15 Posts
Top