DodgeTalk Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have an 03 SXT with a clunking and sometimes squeaking noise I can feel by my feet when driving only over bumps in the city. Driving at hiway speeds the noise goes away completely. I installed new struts about two weeks ago thinking they were the problem since the car now has 40,000 miles. But i'm thinking I was wrong.... Could the control arm bushings be bad ?? They are split open on the top about half way around.. I do know that these are sometimes a problem but how can I find out for sure, without replacing un-necessary parts. What is a new bushing suppose to look like?? Please Help !!!
 

·
Registered
Joined
·
19 Posts
The bushing should not be split, I had the same problem on my 04 with 40,000km. They were replaced under warranty, don't know if yours is still covered. I ctould make a difference, I never noticed mine (a loud stereo solves all problems, lol).
 

·
Registered
Joined
·
793 Posts
Ball joints, tie rods, bushings, I have seen them all squeak and pop. I have even replaced wheel bearings that pop, yes wheel bearings they will roll with no noise at all but as soon as you turn at a stand still it will pop. Lets not leave out cv axles as well.

can you make the noise at a stand still? What if you yank the the wheel left and right rocking the car does it make the noise? If you hit the brakes does it go away?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I can make the noise happen if the car is parked and I bounce the front end up and down it makes a squeeking noise. Also, as I jack the car up the vertical front control arm bushings squeek. I can't get any noise from the suspension if I steer right or left hard. It also doesn't make any "u-joint noise" when I turn tight circles in a parking lot. It will squeek when I slam on the brakes and the front dips down. The front suspension sounds horrible anytime I go over bumps only while i'm driving... It makes the same sound as a loose strut would.... But, i'm pretty positive it isn't the struts... I replaced them and the noise is still there... Everything visually looks ok like tie rod ends, ball joints, and the cv boots aren't torn. but the vertical control arm bushings have cracks in the top. Would this be any place to start?? What do you think?? Please help..
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top