DodgeTalk Forum banner
1 - 2 of 2 Posts

·
Registered
2001 ram 1500 4x4 5.9
Joined
·
2 Posts
Discussion Starter · #1 ·
So ive replaced wheelbearing or hub assembly 3 times on my 2001 4x4. Now when first removed there was so much mangled metal that i lost washer. Which by the way cant seam to purchase anywhere, (so far)!! Though i did break out my grinder and grind off Original spindle nut so that crown was gone. The original nut spins down till it spins freely up against the hub so i ran with it. Put new spindle nut on new install till could put in pin. Yet my hub will last about 2 days then completely destroys its self. This particular time it snaped completely off and as i came to a stop, tire and caliper and rotor passed me by!! Praise be to God that i was only doing 15-20mph!! Felt wobble so got off freeway that i was just doing 80mph on, so yeah feel like He saved my ass on that one!! So heres my question gents WTF am i doing wrong?? Now as for washer thats a no brainer, yet still shouldnt allow for this kind of failer. Seams to me that washer is just to hold hub in place, due to gap in threads and hub unit. So after that im at a loss. Was there a bearing holding spindle up at tube end? Seams to me that there would have been something to keep spindle up and not free floating in the tube. Ive watched video after video read other replacement forums yet this is never brought up. So either my tourchwrench has gone bad and im not getting it tight enough or theres something missing, besides washer.....lol its not up to dealership quals, but it just needs to get me home. Any help and not obvious ridicule would be appreciated.
 

Attachments

·
Registered
2001 ram 1500 4x4 5.9
Joined
·
2 Posts
Discussion Starter · #2 ·
So ive replaced wheelbearing or hub assembly 3 times on my 2001 4x4. Now when first removed there was so much mangled metal that i lost washer. Which by the way cant seam to purchase anywhere, (so far)!! Though i did break out my grinder and grind off Original spindle nut so that crown was gone. The original nut spins down till it spins freely up against the hub so i ran with it. Put new spindle nut on new install till could put in pin. Yet my hub will last about 2 days then completely destroys its self. This particular time it snaped completely off and as i came to a stop, tire and caliper and rotor passed me by!! Praise be to God that i was only doing 15-20mph!! Felt wobble so got off freeway that i was just doing 80mph on, so yeah feel like He saved my ass on that one!! So heres my question gents WTF am i doing wrong?? Now as for washer thats a no brainer, yet still shouldnt allow for this kind of failer. Seams to me that washer is just to hold hub in place, due to gap in threads and hub unit. So after that im at a loss. Was there a bearing holding spindle up at tube end? Seams to me that there would have been something to keep spindle up and not free floating in the tube. Ive watched video after video read other replacement forums yet this is never brought up. So either my tourchwrench has gone bad and im not getting it tight enough or theres something missing, besides washer.....lol its not up to dealership quals, but it just needs to get me home. Any help and not obvious ridicule would be appreciated.
 

Attachments

1 - 2 of 2 Posts
Top