DodgeTalk Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
1999 SLT. Check engine light came on, was told I have an EVAP system leak. Is there a way to check the EVAP purge solenoid, or a way to find the leak. After about 5 minutes at idle the Durango sometimes gets an erratic idle and will shut off, is this a sign of the EVAP system.
 

· Registered
Joined
·
3,712 Posts
The evap system leak is usually a loose gas cap. The other less common source is a disconnected or broken line that runs from the gas tank to the canister. There are also two codes, a leak and a major leak.
 

· Banned
Joined
·
11,654 Posts
Did you check for an error code?
 

· Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
I changed the gas cap yesterday, with no luck. I did take the Durango to a mechanic that checked the computer and he told me their was a leak in the EVAP system somewhere and maybe a bad purge solenoid. As for the acutal code, my wife decided the paper its was on needed to put in the garbage, and I don't remember code.
 

· Keystoner
Joined
·
5,488 Posts
before you go big money fix. did you clear the code? it doesn't just go away after changing the gas cap.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
I didn't clear it, but I can give it a try this evening and see if comes back. I also noticed there is a 1 psi service port in the evap line, does anyone know if there should be a constant 1 psi to verify if the lines upto the solenoid are fine.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top