DodgeTalk Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 1996 intrepid 3.5 recently when i start the car and is cold the speedometer does not work, all the park lights lights up, and when I drive it doesnot shift to second. With the scanner I get error code p1698 after afew times errasing the code the car goes back to normal. Once I got a p0500 error, any ideas what's causing this error? Transmission was replace 3 years ago.
 

·
Registered
Joined
·
56 Posts
I have the same year and engine. How often do you change the tranny oil? Mine will do the same thing, then I know it is time to change the oil and filter. Have you checked your tranny level?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
error p1698

The transmission was replaced over three years ago(brand new), and I have not changed the fluids. The code reading is loose cable, so I started playing with the connectors that goes to the trans controller box (this was in the summer), and for some reason I haven't had the same error. The problem went away ( I think it did). I will keep your idea in mind. Maybe it's time to change the fluids.
 

·
Registered
Joined
·
56 Posts
Well sounds like you had a loose connection somewhere, but based on three years since fluid was last changed you are overdue for one.
 

·
Registered
Joined
·
31 Posts
One or both of your transmission sensors are bad (input/output)...very common failure...most likely just need to replace the right sensor. Cheap fix.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top