DodgeTalk Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I have a '97 1500 w/ a 5.2----101,000 mi. Runs very good, but about 2 weeks ago when I would first start it up when it had been sitting for several hours, it would kind of surge while it was warming up, then run fine after the engine had warmed up some. Has gotten a little worse lately, and today i took it on a little road trip of 200+ miles----now it won't idle most of the time---let off the throttle when you come to a corner and it will idle way down and die b/f you get to the corner. If l keep my foot on the throttle a little and ride the brake, it will run o.k.----Any ideas? TIA!!
 

·
Registered
Joined
·
746 Posts
Have you checked the throttle body and see how dirty it was? My truck was doing this, but mine stopped running weird after it warmed up. I clean the throttle body and it cleaned up. It waould be something simple and cheap 3-4 for a can of carb/throttle body cleaner.
 

·
The Green Machine
Joined
·
1,722 Posts
:stu: Clean the throttle body and sensors...also check your catalytic converter, it could've gotten clogged.
 

Attachments

·
Registered
Joined
·
53 Posts
My guess is its your IAC taking a dump. You can try removing it and cleaning the shaft and plunger on the IAC as well as the hole in the throttle body, this should help for a bit but the problem will likely return. Until you can replace the IAC try foot braking the truck when you are coming to a stop to keep it running.
I had the exact same problem with my truck and replacing the IAC solved it.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
Thanx for the help, fellas!!

As was suggested by a couple of you ----I replaced the IAC and then ran a can of throttle body cleaner through my beast---runs great!---runs better than it has for a long time---total cost was only about $38-----this is a great site---once again Thanx! :thatfunny
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top