DodgeTalk Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Had a problem wih engine light coming on after parking and turning ingnition, does not come on when driving, took it to original dealer where I purchased, and they claim it was a faulty gas cap and they replaced it, light didn't come on for a day. The following morning light came on again. Dealer states it's ok to drive as long as the light is not flashing. Been disconnnecting battery and resetting electrical system to get light to go out
 

·
Registered
Joined
·
3,722 Posts
What year do you have? You can get the code youself 99+, turn the key on (do not start)-off-on-off-on the code should appear on the odometer. There are a couple levels of evaporative system leaks and codes. The hose running from the tank to the canister may be a cause.
 

·
Keystoner
Joined
·
5,534 Posts
you can also swing by autozone. they'll check your code for free.
 

·
Backwoods Hillbilly
Joined
·
995 Posts
And find a new mechanic. Anyone that tells you to continue driving even though the check engine light is on needs to have a clue stick taken upside their head.
 

·
Registered
Joined
·
234 Posts
coachholland said:
Anyone that tells you to continue driving even though the check engine light is on needs to have a clue stick taken upside their head.
Or up there A$$. That is horse crap.
 

·
Registered
Joined
·
750 Posts
It's obviously the dealer saying, "We don't wanna deal with you." That's the easiest thing for them to do is either say, oh it's fine or it's within acceptable standards.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
went by autozone and got a P0440 code
 

·
Backwoods Hillbilly
Joined
·
995 Posts
Have the dealer look at this.

http://autoclinic.net/article/chrysler/ram_canister.htm

There are also a couple of other things it could be. Regardless, the 440 code isn't gas cap related, it is the evap system itself failing. If it was the gas cap, it would give you a 442 or something like that.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
Took it to original dealer 40 miles away, replaced hoses going to canister solved the problem. Thanks almighty wise ones
 

·
Registered
Joined
·
484 Posts
yeah mine is actually lighting up right now, i have a post here with the title "SOME MORE PROBLEMS". went to an autoshop today to decode it and they said my power steering switch is a failure. i ordered the part already and will be getting it on wednesday so i can get it fixed asap.
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top