DodgeTalk Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I won't go into a lot of detail before I know I am posting this in the correct forum.

Basically, I have a 99 1500 v6 that is having a couple of issues, that may or may not be related. First, it is running cold. I have tried several things to resolve this, without much luck. This is how cold it is running. Today here in Omaha, it was in the 40s, not that cold, and I drove around all day today with cardboard in between the AC cooler and the radiator, and it barely got warm. And, when the thermostat would open, the heater would blow cold air.

Second, shortly after starting it, no matter if it is ice cold or I ran into the store for 5 minutes, it will hesitate and misfire. Code from the computer are 'Random multiple misfires. I have replaced the plugs and the wire, but not the distro cap yet. But, none of the symptoms point to an spark issue.

I believe the fan clutch is shot, but not so it never engages, but that it engages all the time, so it is always on 'max' cooling and this puts a strain on the engine when first started. The water pump failed last year and I drove it just a bit too long after I noticed it was failing. I am thinking that maybe the vibrations from the pumps death throws may have damaged the clutch.

Any thoughts on this would be greatly appreciated. And, if I am not posting this in the correct forum, mods, please move it to their.

Thanks,
David Griswold
 

· Registered
Joined
·
716 Posts
Have you replaced the thermostat? Sounds like it is stuck open. I'm not sure what kind of ignition is on your truck. I would go ahead & replace the dist. cap. Do you just have 1 ignition coil? Did you replace the ignition coil wire?
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top