DodgeTalk Forum banner
Status
Not open for further replies.
1 - 16 of 16 Posts

·
Registered
Joined
·
522 Posts
Discussion Starter · #1 ·
Well I have had problems with my truck stalling at stop lights since I installed my new Edge torque converter about a month ago. It also threw codes PO700 and PO841. I cleared the codes and truck drove fine. Well after driving for awhile the truck started stalling at stoplights when I would pull up to them and apply the brakes. After searching the posts I found a post that said that one of the tranny filters might be bad or have come loose so I thought I would replace that. So I did that, but it still stalled. So after reading more posts I found that it might be the EGR valve. So I went to the dealer and told him that I needed an EGR valve for a 2004 2500 Hemi and he gave me an EGR valve, but when I looked at the left front of the engine down by the valve cover where everyone says it is to install it, guess what, its not there. Do 2004 2500 Hemis have EGR valves and if so does anyone of have a pic of where to find the stupid thing. ALso if anyone else had codes po700 and po841 and found the culprit please let me know. SOrry this is so long but I have been messing with it for a month and its really startin to make me mad :mad:
 

·
Registered
Joined
·
522 Posts
Discussion Starter · #2 ·
No comments?
 

·
Registered
Joined
·
3,052 Posts
i have a 03 it does not have one,i think they started in 05.
Our motor is the same as a 1500,no differences.
Pick up a scanner and see whats happening with your truck at a light.
Sounds like a Vacum problem.
Did you check your tranny fluid running in nuetral ,After the install.
 

·
Registered
Joined
·
3,052 Posts
The egr valve would be right under the valve cover,right on the head itself.there would be 3 screw holes there if there was not a valve.
The codes you are getting are bad ones.
i beleive the p0841 has something to do with a switch located under the valvebody,which affects line pressure and gear switching.
Did you get the stalling right after you installed it,or couple days later.
There are 2 tranny filters did you replace both,and did you pull the valvebody out.
I hope you put in new fluid.???.
 

·
Registered
Joined
·
3,052 Posts
I was certain EGR started in 2004.
It should take him about 2 seconds to check.
The 3/4 ton did have a few things different than the 1500s.
And emmisions is 1 of them.
 

·
Registered
Joined
·
3,052 Posts

·
Registered
Joined
·
522 Posts
Discussion Starter · #8 ·
Yep I replaced both filters and new fluid. I didn't notice it till several days later and it only stalls when i apply the brakes hard like when approaching a light or stop sign. I have checked fluid level made sure to seat the filter I guess I will have to take it in
 

·
Registered
Joined
·
522 Posts
Discussion Starter · #9 ·
Oh I forgot to mention that I looked right where the egr valve is supposed to be and I definitely don't have one. I called the dealer to see if I can return the one I bought and I can but will have to pay a re stocking fee. Yippee!
 

·
Silverhemidan
Joined
·
3,277 Posts
Oh I forgot to mention that I looked right where the egr valve is supposed to be and I definitely don't have one. I called the dealer to see if I can return the one I bought and I can but will have to pay a re stocking fee. Yippee!

The dealer did not know that you did not have one....:huh:
 

·
Registered
Joined
·
522 Posts
Discussion Starter · #11 ·
That's exactly what I thought. I told the guy behind the parts counter exactly what it was going on and he said they had the valve in stock so that's what I got. I never would have thought that my truck didn't have an egr valve. Seeing that you have the same year, truck, etc., do you have one?
 

·
paul
Joined
·
951 Posts
allot of guys are staling at a stop if it's not the EGR valve what can possibly be? A sticky PCV valve:dunno:
 

·
Registered
Joined
·
3,052 Posts
Im leaning towards the throttle body as being the culprit.
It would be handy if you could get hold of a friends scanner and see if you notice anything with it.
The throttle bodys do get very dirty,as does the sensor on the intake.
Cleaning them both might help.
 

·
Registered
Joined
·
522 Posts
Discussion Starter · #14 ·
I cleaned the throttle body and intake tube right before I swapped the converter. I also used brake cleaner and made sure not to get any of the electronics dirty. I haven't swapped out the PCV valve so I guess I will pick one up and swap it out. I guess what I am just confused with is why it only does it when I apply the brakes hard.
 

·
Registered
Joined
·
4,029 Posts
Can you tell if the torque convertor clutch in is unlocking? If you keep the RPMs up when you stop, does it still stall?
 

·
05DodgePowerWagon2115
Joined
·
380 Posts
HD Trucks do not have an EGR (2500/3500)

Not sure if you got the answer to your question yet, but the HD pickups (2500/3500) do not have an EGR valve at least up to 2006 because the emissions requirements are different.
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top