DodgeTalk Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi guys. I just bought a 09 dodge caravan sxt 3.8 liter. The guy i got it from said the radio doesnt work. After i bought it and was coming home the radio came on and worked for a little bit then shut off again. That did that a few times. I took the radio out and tried to mess with the wires but still does the same thing. Does anyone have any idea why this is doing that? Is it a known problem? If anyone can help me out that would be awesome. Thanks!
 

·
Registered
Joined
·
51 Posts
You need to test the input power when it is not working. Don’t waste your money throwing parts at it.
The TIPM is blamed for a lot of things but it is nothing more than a junction box with fuses and relays. It can be disassembled and repaired unless it is damaged by moisture and corrosion. The forward control module attached to the TIPM is the switching device that sends power to the items.
If it has power and a ground and it doesn’t work then you know. Always test and don’t jump to conclusions.
 

·
Registered
Joined
·
10 Posts
I have a 2017 GV and the factory radio was ok. The DVD didn’t work and the uconnect was absolutely shit, but everything else worked.

However I replaced that factory radio with an Alpine Halo 9 (Model ILX-F309). I love the change. Makes Bluetooth connections a breeze, music sound WAY better, and there’s no broken/missing USB cover (it actually bothered me).

Overall, I’d just replace it with a reliable radio.
 
1 - 4 of 4 Posts
Top