DodgeTalk Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

· Registered
Joined
·
5 Posts
When I first got my 92 CC it did the same thing. Died as I slowed, or went to take a right hand turn. ( that part was coincidence btw) The dealership changed out the speed sensor on the transmission and I haven't had that trouble since. I had all the symptoms that you described. Hope it helps.
 

· Registered
Joined
·
5 Posts
Speed sensor is in transmission. You need to pull the speedometer cable out. it is attached to that. I am not a mechanic. All they did at the dealership was replace that part. As I said-same exact symptoms as you are having. This repair fixed them.
 

· Registered
Joined
·
5 Posts
All I know is that when mine cut off, it would not start back up right away. There were times when I had to keep my left foot on the brake, and use the right to keep the rpms up so it wouldn't cut off. Like I said before, I am no mechanic. All I do know is that all of your syptoms are the exact same thing mine did. To the letter. I wont say that it couldnt be some thing else, but it is a strange coincidence that the exact same things happened to me and a speed sensor swap fixed it. What you do with that information is of course your business. Hope it helps. Ordinarily I dont chime in on maintenance related stuff based on my lack of experience. I just mentioned it because I thought this might be relevant. Good luck.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top