DodgeTalk Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
370 Posts
Discussion Starter · #1 ·
went out of town last week, roughly 350 mile drive(to Twin Cities).. anywhoo... about 75 miles into trip had to get off the highway( thus deactivating the cruise control) when i got back on the highway, the cruise control wouldnt turn back on.... about a hour later.. i stopped 'cause the little ones needed a "nature" break, couldnt see anything visually wrong with cables, and i couldnt find a seperate fuse for it... it did not work for 2 days.... then out of the blue... it started working again, and has worked ever since as if nothing ever happened... is my D possessed, or is there a dummy switch that disengaged it?... or do i just chalk it up a freak fluke and count my blessings that it works now?
 

·
Registered
Joined
·
1,264 Posts
Usually cruise control is controlled by a vacuum actuator that moves the pedal. I'm not sure if its all electronic in these newer cars or both. But I'd buy a manual and check it out. If yours is vacuum a hose might have popped off or be clogged or something along those lines.
 

·
Keystoner
Joined
·
5,534 Posts
hopefully it's just a fluke, but it's also a symptom of the output speed sensor going bad
 

·
Registered
Joined
·
9 Posts
My 99's cruise worked intermittently a couple of times then stopped altogether. Light comes on but no response. I didn't have time to track it down so took it to dealer. It was the brake pedal switch. $20 part and 30 min labor to install. I should have thought of that and checket it with a test light. The stealer charged me $130 labor (1 hour diagnosis + install). When I wrenched we didn't charge more diagnosis time than it took. Anyway it could have been worse.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top