DodgeTalk Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
My CC doesn't work anymore, nothing happens when i hit the button, no light, no CC? Any ideas where to start 1st? I check, there is no fuse for it? Is this something the dealer has to fix? I would let it go but i have a few roadtrips coming up soon.
 

·
Registered
Joined
·
912 Posts
My CC doesn't work anymore, nothing happens when i hit the button, no light, no CC? Any ideas where to start 1st? I check, there is no fuse for it? Is this something the dealer has to fix? I would let it go but i have a few roadtrips coming up soon.
have your wheel speed sensor checked... it runs your cc,abs,and 4wd, its in your wheel bearing.....mine started to go and i lost my cc to.
 

·
Registered
Joined
·
113 Posts
Sounds crazy, but are you having problems with your battery holding a charge? My break light switch went out and it was causing the ECU to think I had my foot on the break and then the cruise wouldn't work. Changed the switch and the cruise worked. My tip was the battery going down, and I finally caught the break lights staying on. Problem solved.
 

·
Registered
Joined
·
275 Posts
is that the only thing wrong? abs light or anything on?
 

·
Tricked out Ram
Joined
·
12,635 Posts
It is also controlled by the FCM
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #6 ·
Problem fixed, I had the wheel bearing replaced. I guess the sensor was part of the bearing and it was bad. Thanks for the suggestions. You guys rule!
 

·
msmith987
Joined
·
67 Posts
were there any other indicators as to it being the speed sensor? is there a way to test this? I have been w/o cruise for years...no abs light or anything like that...just no cruise control.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top