DodgeTalk Forum banner

Status
Not open for further replies.
1 - 20 of 33 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter #1
Here is my situation:

Just installed long tubes + entire new exhaust system. Since then my check engine light has been on blah blah.

I brought it a garage I thought I could trust. His diagnosis said bad O2 senors that were messing up injector 1, which sounded correct to me. This guy also said my rocker arms were going back and I should get them replace *another mechanic I brought it to said no way they are fine and that guy is trying to screw me*

Fast forward to today I go into another shop and that guy said I can either have him install what I want him to (O2 sensors) for like $60 if I provide parts.

Or he will run the diagnosis himself, figure out what the problem is, order his own parts and put them in. Which I'm guessing @80/hr will be around $250? maybe a bit more?

Which method should I do here have him just put in O2 sensors or have him do it so it can be warrentied.


:help: :help: :help: :gr_patrio
 

·
Inertia ROCKS!!!!
Joined
·
12,164 Posts
Did you delete the cats when you installed your exhaust? What code are you getting? A lot of us that dropped cats or installed high flow cats throw O2 sensor codes, and the O2 sensors are fine. A spark plug non-fouler mod used to push the O2 sensor farther from the exhaust flow may fix the problem. If it's that then you can replace the O2's until you're blue in the face and it will still keep throwing codes. Give us more details.....
 

·
Registered
Joined
·
772 Posts
Buy yourself a spanner & change the sensor/s yourself & save the $60 labour, it aint rocket science. If nothing else you will have new parts in there & still be $60 better off. Whats your mileage as you may be due some replacements soon anyway
 

·
Registered
Joined
·
161 Posts
Discussion Starter #4
If it weren't about 20 degrees outside that'd be exactly what I'd be doing.

"A spark plug non-fouler mod used to push the O2 sensor farther from the exhaust flow may fix the problem"

What exactly is that?

As for milage about 43k or so.

The guy really didn't tell me much basically O2's toast injector 1 .5ms instead of 1.5ms that was about all I got out of him.


/edit

Would I want to just get a blocker for those other sensors? I was told there are 2 sets of 2 in this truck...
 

·
Inertia ROCKS!!!!
Joined
·
12,164 Posts
Again what is your cat situation? Do you have them still? Did you have high flow cats installed? Were the cats part of the header package? Not saying it isn't the O2, but if the cats have been changed, there is a good chance it's not the O2's.
 

·
Registered
Joined
·
161 Posts
Discussion Starter #6
The guy who did it must be a stoner cause I asked him that and he goes "i don't think they are there anymore" So I'm guessing they are gone... would this be a better idea to bring them to a speciality shop and have them tell me whats wrong rather than Ma/Pa on the corner?
 

·
Registered
Joined
·
25,358 Posts
OK you need to look under your truck and see if the cats are there. Sawcut64 is asking you for specific information so he can help you out. Dont go by a so called mechanic that says he dont "think" they are there. He dont know a thing and shouldnt be working on anyones vehicle apparently. Sawcut64 knows what he is talking about on the situation.

Dont take my post as mean but without the right answers he is looking for he is just shooting in the dark at this one.
 

·
Inertia ROCKS!!!!
Joined
·
12,164 Posts
Bizot said:
Sorry I'll be more specifici no they are not there
Then that's your problem, I wouldn't even bother changing the O2's. You can try the non-fouler mod and have a couple of O2 bungs welded in, or stuff them(O2 sensors) up in the heat shield. But chances are without cats you'll have codes, so you can either install them or live with the codes.
 

·
Valdez Racing Team
Joined
·
13,913 Posts
...no cats?...where are the O2 sensors mounted then? the mod he talked about earlier pushes the O2 sensors away from the direct flow of the exhaust (since it flows better now) which solves most of the codes issue...
 

·
Inertia ROCKS!!!!
Joined
·
12,164 Posts
If you have an 03' then you will have two O2 sensors, if you have an 04' on up then there should be four sensors.
 

·
Inertia ROCKS!!!!
Joined
·
12,164 Posts
There should be four sensors, two on each side after the headers for your 04'. So you said there are two, is that two per side or two total?
 

·
Inertia ROCKS!!!!
Joined
·
12,164 Posts
I'm trying......
 

·
Registered
Joined
·
161 Posts
Discussion Starter #18
From what I could see it looked like just 2 but it was all I was looking for.. I'll relook today and look for the other 2. So its 4 right up front?
 

·
Registered
Joined
·
362 Posts
so wait if i delete my cats and just put pipes in their place i should be fine? since i'm not messing with the o2 sensors in theory i shouldn't get codes...am i thinking correctly? andrew
 

·
Inertia ROCKS!!!!
Joined
·
12,164 Posts
Bizot said:
From what I could see it looked like just 2 but it was all I was looking for.. I'll relook today and look for the other 2. So its 4 right up front?
Yes there should be two after each header, so four all together.
 
1 - 20 of 33 Posts
Status
Not open for further replies.
Top