DodgeTalk Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Have a couple of questions on my 06 2500. The last few weeks it doesn't seem like it has the power it should. I'll be going up a slight hill and it won't pull the hill in overdrive, and will kick down to third. This will happen even running 50- 55 mph. Then when I stop, it will idle about 500 rpm's which seems too low. I did the plugs and the air filter about 3,000 miles ago so they are good. Oil was changed 1500 miles ago and is at the correct level. Would a pcv valve or egr valve cause power loss, or is the throtle position sensor starting to go bad? Any thoughts are appreciated and welcomed.


Also, being this is a 2500 and I do pull heavy loads, can I use 5W-30 oil instead of the 5w-20? It just seems like too light of oil for the load that is put on the engine.


Thanks guys.
 

·
PAID OFF!!!
Joined
·
7,637 Posts
Look into cleaning your TB as well as your PCV valve. I bet you feel a pickup from that.

There is a how-to in one of the threads. Do a search you will find it.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thanks, I remember looking at the thread a couple of months ago. Do I need to take the throttle body off to clean it, or can I open the butterfly and clean it that way? Also, where is the PCV valve on the 06's? Keep finding threads on the 05 and older engines, is it in the same location? What is in the oil filler neck with the tube running to the intake? Thanks for the input.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top