DodgeTalk Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
hey first post, but been around the board a few weeks now.. but anyway

my check engine light came on this past sunday when my rpms dropped real low, almost to the point of stalling, then when i stepped on the gas the rpms went back up, but the truck didnt want to move, there was a clunk sound and then went. now since, it hasnt driven anything like what it was, it seems like its reving to high and the shift points are off. its an automatic, have had no other problems like this in the year i got the truck its a 99 1500 with now just over 80k on it. just looking if anyone has had something similiar to this and what i may be looking at repair wise..im taking it in tomorrow AM. thanks.
 

·
Registered
Joined
·
83 Posts
:IDEA: Hey there, I too have a 99 reg cab shorty with the 5.2ltr. I had the same problem, I scanned it. It came back as code # P0720 output speed sensor curcuit malfunction. This truck of mine has two. I took a chance and changed the one on the top of the rear diff ($40.00 cdn) cleared the code, all was good.

The light came on again a month later so I changed the one on the tranny ($55.00cdn) all is good again.

Good luck!!! :rck:
 

·
Chicks dig bench seats.
Joined
·
1,901 Posts
Turn your key on-->off 3x and on the 3rd time leave it in the on position.. Watch the odometer, it will tell you what codes are registering and say DONE when it does through them all.. Let us know what they are.
 

·
Registered
Joined
·
4 Posts
Cluncking noise and not shifting

I have the same sympton. I have had all sensors in transmission replaced, speed sensor at transmission replaced. Rear oxygen sensor replaced and fixed problem for 3 weeks and just failed yesterday. I now find a 2ns oxygen sensor befor catalyst converter that has not been replaced. According to transmission shop oxygen sensor and speed sensors are on same circuit and o2 sensor had a bad ground getting voltage from speed sensor. Go figure. Now I'm reading rear speed sensor on top of differential could also play in this problem.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top