DodgeTalk Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
9,232 Posts
Discussion Starter #1
hey all...i have a 10meter radio...peaked and tuned. i had the power ran from the battery and grounded on a grounding bolt to the frame. i installed an amp and did the same, power from batter, ground on the frame. on low with the amp off, and the truck running if i would key up the mic the engine would become stressed....the volt meter didnt budge, but the rpms dropped about 100-150. if i was idling and put the radio on high and the amp on and keyed the mic, the truck sounded like it was gonna bog down and shut off (probably roughly 300watts) m so i grounded the radio to many diff ways and the amp and still the same thing every time. i couldnt figure it out, finally got frustrated enough to take it out and install the old cobra 29 nightwatch cb peaked and tuned, pushing maybe 25 watts. its pwered at the battery and grounded either at the battery also or on a grounding bolt on the frame, i cannot remember. if i idle and the cb is on low you can hear the engine rpm drop but no volts, and on high its worse, but not like with an amp.

the antenna is a wilson mag mount 1000 or 5000. im not sure what to do, its frustrating the hell outta me!
 

·
Senór Member
Joined
·
17,169 Posts
this might not help ya but i wired my cb to a 12 cig lighter and plug it in that way
 

·
Registered
Joined
·
810 Posts
Have you tried relocating the antenna? Is the antenna grounded to the frame as well? Sounds like RF interference with the injectors and or the ECM. That is the extent of my knowledge you might want to try a professional radio shop in your area.
 

·
Registered
Joined
·
378 Posts
You did mean grounded to the frame, not just to the body, right?
 

·
Registered
Joined
·
9,232 Posts
Discussion Starter #5
frame yes. there is not a ground strap on antenna as it is a mag mount
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top