DodgeTalk Forum banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
262 Posts
Discussion Starter #1
Yesterday i was at a stop light and when i went to accelerate the truck hesitated and acted like it was going to stall. now it does it basically everytime i am stopped and go to go. No CEL. trucks a 99 1500, 5.9, 126,xxx miles. I have no idea what it could be. thanks for any help
 

·
Registered
Joined
·
353 Posts
x2 also replace the cap and rotor, plugs, wires....it could also be carbon in the throttle body.
 

·
Registered
Joined
·
262 Posts
Discussion Starter #4
travisblues- does your truck do it all the time or just when you go to accelerate
 

·
Registered
Joined
·
10,824 Posts
Ok, i have a couple things in mind. Could be the tps (throttle position sensor) or possibly the cat.

also, do you notice any surging or anything while driving down the road? does the rpm gauge jump around any at all?
 

·
Big Green
Joined
·
8,318 Posts
You also say no light have you had the computer checked for stored codes
 

·
Registered
Joined
·
262 Posts
Discussion Starter #7
jmw132001- I wouldnt think it was the cat. i just had a new magnaflow hi-flow cat and magnaflow y-pipe put on. And yes it does surge while driving. when in overdrive the rpms will jump around.

elliotcarlose- no i havent had it checked for stored codes
 

·
Registered
Joined
·
10,824 Posts
jmw132001- I wouldnt think it was the cat. i just had a new magnaflow hi-flow cat and magnaflow y-pipe put on. And yes it does surge while driving. when in overdrive the rpms will jump around.

elliotcarlose- no i havent had it checked for stored codes
do a full tune up on it. plugs, plugs wires, cap, and rotor. Mine done the same crap before and i done a full tune up and solved the problem.;)
 

·
Big Green
Joined
·
8,318 Posts
It would not hurt to have the codes read. I know my truck ran like crap something like you explained and it showed no CEL it was the O2 sensors but did store a code.
 

·
Registered
Joined
·
9,206 Posts
if your not ready to spend money. try to index the tps. because of the static resistor inside you may get false readings through it. to drill the holes out one drill bit size larger and rotate to either rt or lft can temp change the surge and hesitation condition. to rotate it the wrong direction will only temp make the prob worse. release it turn it the other way tighten again & try. occasionaly you will need to add washers behind the screws. something to try for free.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top