DodgeTalk Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1
Hey guys I have a 2001 ram, and recently my passenger side brake light went out. I replaced the bulb with a new one but didn't check to see if it worked, just assuming that it was a new bulb, it would work. Well come to find out, the new one doesn't work either. The light goes on with my headlights, but when I hit the brake, it doen't get any brighter. I replaced it again, and had someone hit the brake while watching the bulb. It looks as if the bulb sort of flickers a little bit when hitting the brake, but doesn't get any brighter. Do any of you guys have an idea what is wrong? Thanks. :VHOT:
 

·
Registered
Joined
·
1,987 Posts
try to check the wires going to it, they might have come loose at the connections under your truck
 

·
Hemi Nation
Joined
·
260 Posts
RE: Brake Light

I had the same thing happen in my '99 Ram, only on the drivers side. Driving lights worked but no brake lights. The socket itself was bad and I had to get a whole new wiring harness ($120+ with installation). You may want to try to find just the socket at a junkyard and splice it onto the existing cable to see if that works.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #4
Yea that is what my step-dad thought it may be. I think I will wait awhile, it's snowing right now, and go to a junk yard like you said or try to find one cheaper elsewhere. Hopefully that will fix it, thanks.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #5
I don't think any of the wires are unconnected, because the light goes on with my headlights, it just doesn't get brighter when I hit the brake.
 

·
Registered
Joined
·
607 Posts
Does the turn indicator work on that side? It's the same filament, and if so, the wiring to the socket's OK and the problem goes to the changeover contact in the turn switch that disconnects the brake feed when the turn indicator's are activated. Likewise the hazard switch.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #7
No actually my turn signal nor my hazards flash on that side, so do you still think it is the socket then?
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top