DodgeTalk Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
238 Posts
Discussion Starter · #1 ·
As the title says, my blinkers don't work. I have checked the fuses both in the cab and in the engine bay and all appear to be fine. Any thoughts on what could be wrong? I don't want to have to go someplace and hear something bogus like "Looks like we'll have to replace the wiring harness," and end up paying way more than i need. :help:
~Derek
 

·
Banned
Joined
·
3,902 Posts
olsarge said:
You are out of blinker fluid.
I hate it when that happens!
 

·
Registered
Joined
·
238 Posts
Discussion Starter · #5 ·
olsarge said:
You are out of blinker fluid.

Actually check your bulbs, one or more is probably out.
haha. good one. (sorry, but my sense of humor has taken a coffee break).

i would check the bulbs, but they all work. when i push the hazard button everything works fine: the front blinkers, the rear ones, and the turn signals inside. i'm thinking it has something to do with the wiring, but i'm no mechanic.

~Derek
 

·
Registered
Joined
·
815 Posts
olsarge said:
You are out of blinker fluid.QUOTE]

Had that happen once. My Farfagnutin bolt was loose.

Could be the flasher too. Or it could be the truck just doesn't want to turn at that particular intersection.
 

·
Cass_A_Nova
Joined
·
1,258 Posts
kitcar said:
olsarge said:
You are out of blinker fluid.
Had that happen once. My Farfagnutin bolt was loose.

Could be the flasher too. Or it could be the truck just doesn't want to turn at that particular intersection.
:thatfunny :thatfunny :thatfunny :thatfunny
Probely wiring but it could be as little as a little bit of wiring that is fried.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top