DodgeTalk Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
RE: 1996 Grand Voyager

For the first time in any vehicle I've ever owned, the ABS light came on. I checked the owner's manual and it's apparently OK to drive, I just won't have ABS. Van drives and brakes fine.

Had front brake pads done back in May (about 5-6K miles ago) and just had front and rears checked again by my mechanic about 2 weeks ago as we are preparing to move cross-country (from GA to TX) within the next 4 weeks.

Of course, I need to get this fixed. And, of course, this type of stuff always seems to happen on a weekend. Sooo, any ideas what the problem could be?

Thanks for any and all replies!
 

·
Registered
Joined
·
108 Posts
Discussion Starter #2
OK.....after sitting overnight, I start it up this morning and drive it around the block, and the ABS light isn't on anymore. Talk about a quick fix. Let's see if it makes it to church and back without the light coming back on.
 

·
Registered
Joined
·
108 Posts
Discussion Starter #3
UPDATE: Drove the van all day Sunday and the ABS light didn't come on at all except during start-up as is normal. Must have been some glitch. Let's hope it stays that way, at least til I get to TX. Gotta love Mopar!!!
 

·
Registered
Joined
·
34 Posts
when the light comes back on...check to see if the horn/cruise works. i believe this van had a clockspring recall. it is the switch that allows these items to work while you turn the steering wheel....your dealership should be able to tell you if it was....goodluck
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top