DodgeTalk Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
guys I need to run a trans issue by you, A/T '98, 12V,, , just bought it so I dont know the history on it exactly, it ran good on the test drive and made all gears fine, I made the deal ..... then I steam cleaned under the truck in there wash rack before going home as it was a major greaseball from the radiator back underneath, ...more on that later.

computer is throwing 3 codes.

P0751 O/D Switch Pressed (Low) More Than 5 Minutes

P1757 Gov Press above 3 PSI in gear with 0 MPH

P1763 Governor Press Sens Volts Too Hi

when getting on the freeway it makes all gear changes clean and climes into overdrive if your into it pretty good like half throttle or better,....... as soon as you lift up on the throttle to maintain speed it.......I guess it unlocks the converter?? it kinda free revs until it slows down then grabs and you can tell its going to fast for where the trans or converter is. basically really rpm'ing the old girl at that point.

fluid is clean and smells ok, trans showed a little grime to it but not bad, its defiantly been out of the truck at some point and has a big trans cooler up front. I like how it shifts now nice and firm better than a stock unit. .

one more piece of info... somewhere in the paperwork that the dealer had done work on the truck was to replace the throttle cable, ball studs and re calibrate some sensor associated with the cable ....tps??....the sales guy was suppose to copy all the pages for me but I dont see it in my stuff but I do recall reading it at the dealer when I had there folder on the truck.

did the guy not set the throttle sensor right causing the trans issue??? weird the trans works right if I romp on it and into the throttle pretty good??? kinda like a tps to trans issue?... what do you guys think???



Thnx Bud.
 

·
I disgaree...:)
Joined
·
2,032 Posts
It does sound like the converter is doing something funny regarding the lockup. It should unlock when you let off the pedal and relock when you get back on it. The other deal you mentioned is what sounds completely wrong. I suppose it is possible that the TPS is throwing it off, it is also possible that a bad ground could be doing it.
 

·
Blowin n' Goin
Joined
·
3,692 Posts
When we my dad had a 12v it would start doing the throwing in and out of lock up like your describing, he replaced the TPS and all problems were solved. Thats where I would start and work from there.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top