DodgeTalk Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I recently replaced the auto transmission in my truck. My friend dropped a wrench in between the frame and starter wires and I believe he shorted something. With everything back together on the truck, it won't start with the key. No click, no attempted turn over. But if i short the starter itself on the frame or straight wire it to the battery, the starter works fine. I checked fuses and haven't found any blown. Perhaps a relay? What could my problem be and how can I fix it? Any help is appreciated!
 

·
Registered
Joined
·
4,137 Posts
I recently replaced the auto transmission in my truck. My friend dropped a wrench in between the frame and starter wires and I believe he shorted something. With everything back together on the truck, it won't start with the key. No click, no attempted turn over. But if i short the starter itself on the frame or straight wire it to the battery, the starter works fine. I checked fuses and haven't found any blown. Perhaps a relay? What could my problem be and how can I fix it? Any help is appreciated!
Starter not grounding? (still loose?)
 

·
Registered
Joined
·
5,210 Posts
But if i short the starter itself on the frame or straight wire it to the battery, the starter works fine.
??? Ground issue? A assume you are powering the solenoid wire (small one). Did you try swapping out the relay?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Well i hooked everything back up, tightened the battery terminals, and just tried to start it for kicks. Works perfectly. No idea what the problem could have been. Should I be worried? Turned it off and back on multiple times and works just like new.
 

·
Registered
Joined
·
4,137 Posts
I recently replaced the auto transmission in my truck. My friend dropped a wrench in between the frame and starter wires and I believe he shorted something. With everything back together on the truck, it won't start with the key. No click, no attempted turn over. But if i short the starter itself on the frame or straight wire it to the battery, the starter works fine. I checked fuses and haven't found any blown. Perhaps a relay? What could my problem be and how can I fix it? Any help is appreciated!
... Sounds like starter was not grounding.

mattm9614;5951225 No idea what the problem could have been.[U said:
Should I be worried?[/U]
... Light ish gauge ground straps to frame, body, etc may have been overloaded when "shorting starter to frame to start engine"; would be good idea to check them to avoid gremlins/headaches in the future.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top