DodgeTalk Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Just replaced the auto transmission in my 97 1500. When installing a new cooler line, it crimped. Not extremely, but i fear it may cause too much back pressure and cause a leak or worse. What is a cheap way to fix this? I read online i could buy a short length of aftermarket hose and cut my metal line around the crimp,replacing it with the clamped hose. Is this a safe alternative to buying a whole new 40 dollar high pressure cooling line?
 

·
Registered
Joined
·
4,137 Posts
Just replaced the auto transmission in my 97 1500. When installing a new cooler line, it crimped. Not extremely, but i fear it may cause too much back pressure and cause a leak or worse. What is a cheap way to fix this? I read online i could buy a short length of aftermarket hose and cut my metal line around the crimp,replacing it with the clamped hose. Is this a safe alternative to buying a whole new 40 dollar high pressure cooling line?
... If it's not too close to hot exhaust etc it's definitely a safe alternative, aftermarket aux coolers are often mounted this way; could get their hose.

... DK best hose to purchase; needs to be for "hot oil service", and prefer hose rated for 300*F "if you can get it", especially if its the hot converter discharge line going to bottom of rad ... Others can give you better advice for hose.
... Many say "do not double clamp"; I think it's ok/good if clamps are placed as close together as possible, clock them 180* or as necessary; I'd buy/install 4, especially if splice is obscured or underneath truck. my02

... If tubing cutters are used to cut lines, watch as they tend to swage/shrink the metal lines ID at the cut: could chamfer the cut, or try using a taper punch to restore the lines original ID; remove all cuttings!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Thanks guys. Got it fixed with that hose. Next problem.
The trans now shifts through 3 speeds manually but will not shift automatically in drive. Also, it does not drop into overdrive. What could my issue be? Speed sensor? The previous owner of the trans had no problems like this.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
I filled up my fluid with the engine running and hot. Filled it to almost max. Drove a few miles and now it's saying over max. Could this be part of my problem? And should i drain some out?
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top