DodgeTalk Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hey guys, long time no talk. My older Caravan ('92) went into limp-home tranny mode immediately after I had used the under-hood jack to lift the vehicle for a passenger side front brake job. I know that there are lots of delicate electrical connections that have to work for the tranny to shift; are any of them near the jack storage? The tranny will not shift out of 2nd no matter what, either automatically or manually. Also, where in hell is the ground strap connection to the transaxle? Maybe it's the problem. Any help would be greatly appreciated.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
Four-speed auto.
 

·
Registered
Joined
·
1,181 Posts
Does the problem still exist. I get this once in awhile, and if I shut van off for a couple minutes, it goes away. Not sure why though, not concerned until it stays stuck in limp mode.....Brad
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
Yeah, its been like this for a couple months. I haven't tried unhooking the battery, but I have a feeling that that won't work.
 

·
Registered
Joined
·
1,006 Posts
I would trace any wiring starting at the transmission and follow it back checking any connections/connectors that you find (clean & tight) you find and inspecting the wiring for cracks or breaks

Eventually you will find yourself at the transmission control unit and you can check that to ensure that all connections are clean and tight

I realize this is pretty generic advice but I find that checking the simple things first can sometimes save time and $
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top