DodgeTalk Forum banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Not that long ago, I replaced the fuel pump. Ran great for a while. Last weekend I was adding freon, letting the engine run. Out of blue it died. It has not started since. Its not getting fire now. No voltage to the coil. All that fresh freon just going to waste as I search my manual and forums for some help. Any ideas would be appreciated!

1989 TBI 318 Auto
 

·
Do It In A Van
Joined
·
8,045 Posts
Are you at least getting fuel?

Sounds like a possible crank sensor problem.
 

·
Do It In A Van
Joined
·
8,045 Posts
Yeah...it sounds like a crank sensor problem.
 

·
Registered
Joined
·
313 Posts
could be ASD relay
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7
It throws a trouble code "42" which is the asd or no z1 voltage. I performed a voltage test for the relay which showed that it was good, but I still get the "42" code. The z1 voltage tested good too. I got the test from a post in this forum.
 

·
Registered
Joined
·
313 Posts
check fuseable links.
 

·
Registered
Joined
·
313 Posts
check fuel pump relay also.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #10
Where are these fusible links? My manual just says check them, not where they are. I have looked and I just see a mess of wires. Also, I didn't think I had a fuel pump relay.
 

·
Do It In A Van
Joined
·
8,045 Posts
Just realized your van doesn't have a crank sensor....sorry.

You have an ASD relay which routes power to the fuel pump, coil, fuel injectors, etc.

These go bad occasionally.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #13
The problem was the asd relay. I unbolted and banged it against the battery a few times out of frustration. Water dribbled out of it. I tore it apart and found all the parts corroded and rusted. I cleaned it up, sanded the points and then it worked. I replaced it (wouldn't last long the way it was) and now it is great. My appreciation to this wonderful forum!
 

·
vanner
Joined
·
519 Posts
Good, glad to hear it worked out.
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top