DodgeTalk Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Iv got an 88 w100 pickup ive picked up a tps map and coil,
Its got some hot run and start issues.
If its just a bit hot it shuts down.
Its got 180° thermostat. At shutdown
Its still cool enough to remove the rad cap so not overheating.
Pop the hood let out heat for a few minuts it starts runs and goes. Only at slow speeds hauling a load does it get hot enough to shut down.
At cold start ignition on i tap the throttle once it starts in 1 or 2 crank rotations without the tap its random weather it will start before the batts dead. So new parts going in .
Ive replace the guage temp sensor
Tb temp sensor and ecu temp sensor, and o2, in last couple years to fix the heat non start issue, only last couple weeks found tps may be an issue when i started tapping throttle after key on.
As for the coil its got a bit of oil film on the top seam its mounted sidways and probably leaking, the pos+ term has a points type cap mounted ?
Any clues as to why? Its not in any schematics ive looked over the only schematic i have that shows or matches my truck is a 90s model with tb temp sensor. 88 89 didnt show tb temp.
Is the cap there to protect the ecu? Or extende or flatten the pulse to the coil?
Or just installed by someone as a try and see mod?
 

·
Registered
Joined
·
147 Posts
Factory install was as a noise suppression capacitor to help the radio.

It can be removed if you wish; just be prepared for ignition noise in the radio if it's out of circuit.

RwP
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thank you, uhhh, whats a radio? Lol,
Couldnt hear it any way with all the wind noise leaking around the window headed down the highway.
Forgot about noise suppression. Stupid recaptur verify not working.5 times now
 

·
Registered
Joined
·
147 Posts
HUH? WHAT DID YOU SAY?

SPEAK UP SONNY, MY EAR TRUMPET IS BACK AT THE HOUSE!!! 📣

But seriously, you might want to replace the window glass runs and get some of that wind noise down.

RwP
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
First needs new body to frame rubbers so the driver side door closes properly, cab gets twisted when the old rubber sags 2 inch body lift in its future, only found passenger side win trim on line but havnt looked much. Just found my map sensor not fit. Tabs in sensor are different, part ordered 23bucks part found same terminal connector 87 bucks,
Out with the meter and vac pump.
Speakers dry rot on the truck so wind noise keeps the wife quiet lol
 

·
Registered
Joined
·
381 Posts
Hot stall/hot no start could be a defective hall sensor. Could just be a bad coil too. Coils shouldn't leak.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Swapped out the coil 2 days ago will update, old one was external resistor type without a resistor, the coil was oil filled type covered in oil but no oil leaks on eng in that area.
 
1 - 7 of 7 Posts
Top