DodgeTalk Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
216 Posts
Discussion Starter · #1 ·
as stated I have a 1984 dodge W150 with a 360, the engine has about 110K on it, but here is what it is doing. it runs fine until about 3000 RPMs and then it seems like it starts missing, it will rev further but it feels like it cuts out constantly.here is what I've done: changed the cap, rotor, plugs/plug wires, rejetted the carb(moved to lower elevation) adjusted timing, adjusted float level it's a holley truck avenger 670. the ignition is a MSD6A, cap and rotor, and coil is blaster 2, it has headers but the internals are stock. I'm thinking I've got a cam lobe or maybe even a bad lifter/bent pushrod, but I wanted to see what you guys thought, it has been back firing through the intake a little bit when under hard acceleration, hence my diagnosis. what do you guys think? THANKS
 

·
Registered
Joined
·
216 Posts
Discussion Starter · #2 ·
just one more thing, it has a 727TF behind it, and it's only like 3 yrs. old, and it has started to slip, the ATF isn't burned or discolored yet, but it only does it when it's cold, any tips on this or am I needing another rebuild? Also it does have a trans. cooler, and it don't work to hard anymore, just mainly my daily driver.
 

·
Registered
Joined
·
194 Posts
I`ve seen conditions, where `popping`, or backfiring thru the carb, indicated a worn cam lobe, bent pushrod,(as you suspected), or broken valve spring, or it could be a bad lifter, which isnt moving the valve, in which case, it takes the cam with it too...
 

·
Registered
Joined
·
2,140 Posts
The 727 will have problems when cold. You can put it in gear and it will take a few seconds to engage. This is caused by the fluid draining back out of the torque convertor. I believe there is a kit you can install to cure this problem or just let the truck warm up in neutral, when in neutral the fluid pump runs and fills the torque convertor. Has the fluid and filter been changed? A partially clogged filter will also contribute to this problem.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top