DodgeTalk Forum banner

Status
Not open for further replies.
121 - 137 of 137 Posts

·
Registered
Joined
·
9,206 Posts
It is a mystery that is for sure but I like the spray pattern of the new injectors. They have like 5 or 6 holes in a star shape while the stock injectors have one hole.
I must b misunderstanding something. who has stock 27lb injectors and what make are they, seimens'? any bosch injector 27lb should be four hole. right?
 

·
Registered
Joined
·
9,206 Posts
do u run lean or have an air/fuel ratio gauge on it?
 

·
One day at a time
Joined
·
1,003 Posts
Discussion Starter #124
I must b misunderstanding something. who has stock 27lb injectors and what make are they, seimens'? any bosch injector 27lb should be four hole. right?
Sorry... I thought the stock injectors are 27lb. I read that somewhere I could be wrong.



do u run lean or have an air/fuel ratio gauge on it?
Yeah I have a AEM air/fuel gauge. The readings jump around a lot but at cruise it stays in 14 area. Now when I let off the gas while cruising it goes really lean... it bottoms out. Gauge shows (---) This could be just normal but with the old engine it didn't bottom out that bad.

To be honest the ECM is all whacked out right now. The engine wants to die when I come to a stop light. I have to keep my foot on the gas pedal. I'm hoping that when Ryan gets my tune finished this will not happen.
 

·
Registered
Joined
·
9,206 Posts
22lb stock Siemen brand injectors at 43.5lbs/ 3 bar, fuel pressure.
 

·
Registered
Joined
·
9,206 Posts
any updates?
get it fixed?
 

·
One day at a time
Joined
·
1,003 Posts
Discussion Starter #127
any updates?
get it fixed?
What I said in the earlier post about letting off the gas and the engine going lean... I talked to Ryan about it and he said "It is normal.... decel fuel cut off"
So I guess it's ok for the engine to do that.

Got the #39 injectors in with Ryan's tune. Right now we are back and forth on getting the tune right. I sent him a data log after he sent me the first tune. He took some fuel out of it because it was running rich and sent me the revised tune. The engine is running better now but he wanted me to send him another data log. I sent it to him today. I think pretty soon he wants me to send him a WOT data log... he mentioned it.

The throttle response is unreal... there is no lag whatsoever. I had to rotate my tires because I have burnt the rear tire up....lol There is some tread left but it's kind of thin.

Been driving the truck around town and get a bunch of thumbs up and people coming up asking questions. lol

I bought the TrueTrac differential and a master rebuild kit. That will be here tomorrow. I'm going to try and do this myself sometime pretty soon.

The main question is do I have to remove the pinion? Back in 2006 I had the rearend rebuilt while adding 4.56 gears. I'm going to use the same gears. I'm thinking the pinion bearings aren't worn out. Between that time I haven't put a bunch of miles on it. Been riding my motorcycle mostly and at one time the truck sat for year because I drove a company van everywhere.

Thinking maybe I can install the TrueTrac with new bearings and not touch the pinion.
 

·
Registered
Joined
·
9,206 Posts
you got a new pinion bearing with the kit? that bearing is doing 4xs the rotation the wheels are. but its up to you.
so the stalling at a light might be the throttle stop or the iac solenoid parameter needs to be set. the throttle stop needs to set near 50rpm within the iac computers spec. this is done both in the tune and manually were you want it.
I have my pcm set at 700rpm and dialed the throttle body to it. RAD cams normally are set higher.
then you get into the ac pump spike! if my pump would engage at a light, the truck would drive itself through the brakes. my ac spike was an additional 275rpm! with the ac running the idle was like 1000rpm. had the pcm drop the ac spike to only an additional 100rpm and now I barely notice.
I'm hoping your problems are only simple.
 

·
One day at a time
Joined
·
1,003 Posts
Discussion Starter #129
The only reason I don't want to remove the pinion is.... I might muck something up... :(

I might get in there and decide to do it but at the moment I'm kind of paranoid about it.

I bought the crush sleeve eliminator made by Yukon so it's in the back of head. ...lol

The stalling at the red light has been fixed. Ryan told me to open the blades on the throttle body 3/4 turn. The F&B throttle bodies don't let enough air through compared to stock throttle bodies. With the ac on the truck idles at 850 in gear. I noticed that yesterday while coming home from work.... it's starting to get hot down here.
 

·
Registered
Joined
·
9,206 Posts
hooray! that hick up was easy. one down. that one took me a while to fix!
whats next!
 

·
One day at a time
Joined
·
1,003 Posts
Discussion Starter #131
hooray! that hick up was easy. one down. that one took me a while to fix!
whats next!
Besides installing the TrueTrac that's about it.

Me and Ryan are still working on the tune. It seems the more I send him a data log and he sends me a revised tune.... the faster this truck gets...lol

I've got a drive shaft loop I'm going to install sooner or later.
 

·
Registered
Joined
·
9,206 Posts
I had a drive shaft drop out!
WAHOO! fun
 

·
Registered
Joined
·
36 Posts
I haven't touched my build in a long time...had to go on disability, a big cut in pay. Starting to save some money for next truck part which will be a tune from FlynRyan. Good to see that you've got your truck up and running. I've been following your post.
 

·
One day at a time
Joined
·
1,003 Posts
Discussion Starter #135
Good to see that you've got your truck up and running. I've been following your post.
Cool glad you've been following. I'm adding a Vortech V3 Si trim supercharger. Going to be running 8-9 psi boost. Yesterday and today I dropped the gas tank and added a Hipoteck -6AN fuel kit. Had to install a 450lph fuel pump. The kit has the aluminum fuel rails and now the fuel system will be a return type system. Pretty nice fuel system.

I would have completed it today but Hipotek sent me wrong length hose for the module. I would have went to a local auto parts store but the hose has to be submergible type. The parts store can't confirm if their hose is submergible type. Richard at Hipotek mailed the correct length hose which is submergible type. Waiting on the mailman now..lol

Have to change the cam to a blower type cam. Cam specs is .236/[email protected] .570/.584 lift 112LSA.
 
121 - 137 of 137 Posts
Status
Not open for further replies.
Top