DodgeTalk Forum banner
Status
Not open for further replies.
1 - 16 of 16 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter · #1 ·
My trucks has ran ruff for the last few days but yesterday I started it up and it was shaking pretty bad. So I turned it off and restarted it, this time it ran worse and the check engine light light came on. I Checked the code and it was p0303 which is Cylinder 3 Misfire Detected. Any ways my truck has only 19000 miles and is stock. Do you guys have any ideas what could be wrong with it? Now it seems still a little ruff but the check engine light went away. Thanks for your help!!
 

·
Registered
Joined
·
25 Posts
usually a single missfire code is caused by a spark plug, i know that chrysler was changing some of the smaller engine spark plugs not sure about the v8's but i would take it to the dealer, you might get a new set of plugs. Or you could have just got some bad gas seeing as the light whent away. I'll check and see if there are any tsb's on that
 

·
Registered
Joined
·
25 Posts
theres no tsbs on that so i would say its bad gas or a bad plug, its still under warranty so take it in to your local dodge boys and they will take care of ya :SPIN:
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #4 ·
Hey, thanks for the reply, I'm taking it in tomorrow at 10am, I'll post what the dealer says.
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #5 ·
Well, I took it in to the dealer this morning to find out what was wrong. He told me it was a misfire on cylinder #3 and they put in a new spark plug. It seems to idle a lot smoother now so hopefully thats all the problem was. Also I told him that something on my power steering was dripping so I get a new rack for the steering. Glad I got this all taken care of without any complaining from the dealer.
 

·
Registered
Joined
·
1,170 Posts
It figures they would only change the 1 spark plug.

My 4.7 seemed to go through plugs around every 25K. I would notice the fuel economy dropping and slight ping. Change plugs and all was good for another 25K.
 

·
Registered
Joined
·
128 Posts
Discussion Starter · #7 ·
Yeah, and also I check under the hood to make sure they put everything back on like it was and guess what, the air box in the center of the engine wasnt bolted on with the two bolts only one and I had to mess with that when i got it home. You would think that they would remember something like that. :crazy:
 

·
Registered
Joined
·
266 Posts
Nice to hear that there was nothing bad with the engine. But as of last night my engine went on and I am not sure why. I here everyone talking about a code reader. Where can I get one of those and if one could be recommended it would be great. The engine seems to be running smooth. So I wouldn't know where to start. But I guess with a code reader it would be more helpfull.
 

·
Registered
Joined
·
25 Posts
your truck has one built in just cycle the key on,off,on,off,on (not start) and where your odometer is it will give you a p-code just post that and we can tell you what its for, of call your local dealer and they can tell you.
 

·
Registered
Joined
·
266 Posts
Damn, that is sweet. I wish I would have known that 30 mins ago. I removed the positive Battery terminal and cleared it and now the engine light it not on.


Just wondering if my 2000 grand cherokee is that way to?

but hopefully it doesn't come back, but it does, I will try that key trick.

Thanks again.
 

·
Registered
Joined
·
25 Posts
i dont recomend removeing the battery cable just because it clears valuable info that the computer uses to help the truck run correctly, if its a problem that is no longer present the computer will clear itself eventualy.
 

·
Registered
Joined
·
266 Posts
That is good to know. I was always told that was the way to removed the engine light and if it comes back then you know you have a problem. But I will make sure not to do that again.
 

·
Registered
Joined
·
266 Posts
My engine light came on again and I tried doing the key on and off a few times, with out starting the car and did not get any codes. I never heard that you could do it that way, I thought you needed a reader. Anyone please help.
 

·
Registered
Joined
·
414 Posts
Just turn it 3 times on off and the the 3rd time leave it on. If there are no codes it displays the word "done" where your mileage would be.
 

·
Registered
Joined
·
266 Posts
Guys thanks, it worked that time. I got code P0455. I looked it up and got Evaporative Emission Control System Leak Detected (no purge flow or large leak).

I am going to tighten up gas cap and then reset ECU to see if this shows up again.

Thanks again.
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top