DodgeTalk Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
1,055 Posts
2k2_AtlanticBlu said:
They must have changed that at somepoint because my '02 came with the orange stuff from the factory.

Andrew
Yes, they did because my '01 has the orange and it clearly states in the factory service manual to ONLY use the orange. I had a run in with my dealer over this when I had a flush and they put green back in.
Long story short, the service manager and I got the Chrysler Engineer for the cooling systems on the phone and he said to use the orange, it was the preferred coolant for the 4.7L. We asked if we could use the green. He said yes you can use it...but its not recommended.
So, from the engineers who designed the cooling system...use ORANGE.

The service manager was actually surprised by the engineers answer...he thought for sure the engineer was going to say they only used the orange for longer maitenance intervals, not because its a better coolant for the 4.7L.

You also can't mix the green and orange, you must flush the coolant system completely if you're switching from green to orange. Plus you must use only distilled water with the orange. Actually you should always use distilled water with any coolant as tap water will cause you're radiator to scale up.
 

·
Registered
Joined
·
1,055 Posts
Thanks for the replies guys, I'll see what coolant they put in. Hercules, you have the number for that Dodge Engineer? I have a feeling my brother might have to call him.
__________________

Sorry, the service manager called from his office...put the call on speakerphone so I could hear everything. I know he called to Arburn Hills? Michigan. I was wanting to know why it stated in bold print in the Factory Service Manual to only use the orange coolant and not the green. I told the service manager if Chrysler says the green is OK, then its fine with me. To tell you the truth, the service manager and I were surprised when the engineer said to only use the orange. Maybe Chrysler discovered the green was causing problems with the 4.7?
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top