DodgeTalk Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Anybody experience this before? When attempting to start the truck the starter engages, it sounds normal but won't fire. I'm fairly sure its getting fuel because I can smell fuel after attempting to start it several times and the injectors are clean. The plugs and wires are ok. So is the ignition module or coil bad? Anyone have an educated guess?

The truck is a 99 Dakota Sport, 3.9 V6, 5sp, 2WD w/ 60k

Thanks for your time

-Offcamber
 

·
Registered
Joined
·
35 Posts
Is this an on going problem (truck won't start) or does it start sometimes? Have you checked for spark? On my 02 it would happen only once in a while. When it would happen there was no fuel pressue, per the dealer it was the low idle sensor, it runs fine now. Also have you checked for any codes?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Problem Solved

I had to replace the distributor pick up plate underneath the distributor rotor. I'm told (by the guys @ Autozone) that Dakotas have a habit of needing those replaced. While I was in there I cleaned the contacts on the cap and rotor and she runs like a champ. Thanks to everyone for the help.

Offcamber
 

·
Registered
Joined
·
67 Posts
First you have to determine what you don't have...I know you smell fuel but do you have fuel pressure???? You need to check for spark to see if your getting good spark.There are many things that can cause this problem....If you have spark don't bother with the pickup plate it is good...If you don't have spark take dist cap off have someone crank the engine and see if the reluctor inside of the dist is turning.....Check for fault codes this is very important...if you don't diagnose properly you will be spending alot of money fixing this truck...IF you have any questions email me at [email protected]
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top