DodgeTalk Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Good Afternoon Everyone,
I hope everyone is having a safe and great day.
Information about my car
2014 Dodge Charger 5.7 with 138,000 miles stock besides a ported throttle body and a Tazer Performance.
I have always had the free oil changes with dodge and now that that has run out I have switch over to Royal Purple 5-W20 with a Moblie 1 Oil Filter which I changed last night.
Driving the vehicle today I notice that the oil pressure sat at 59 PSI at idle after warming up. When driving up to 2000 rpm driving @ 40-70 mph. When I accelerate to 3500 rpm goes up to 65PSI and if I go to 4500rpm it goes over 70-72. Is this normal. I never took into consideration the PSI when I was having it change by Dodge. Just wanted to make sure this is normal. I have research many forums and can't find a correct answer as people have different readings. If you guys/girls can please help me, I have a trip for a funeral coming up and would like to have things not break down on me.
Once concern I have is that when I used to do the Oil changes on my 5.7 2008 ram i would fill the oil filter first to the top before puting it on. This time i only filled about 1/2 to 2/3 full. Could this cause an increase in pressure for the oil?
Greatly appreciate any one that chimes in please.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
Another note, After about 50 miles of driving when I came to a stop it would drop down to 44-47 psi and jump back up to 59 psi when i started to accelerate.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top