DodgeTalk Forum banner

Status
Not open for further replies.
1 - 20 of 31 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
This may be a stupid question, but I have a 2008 Charger and when it goes into Mds mode I can tell and the evic says fuel saving mode. On the 2009 Ram there is no indication, that I can tell of if it goes into mds. Does anyone know if there is any indications when this occurs?
 

·
Woosah!!!
Joined
·
421 Posts
I have not seen an indication. But I read somewhere that the MDS resets when you disconnect the battery and can take some time before it starts working again so since my truck only has 400 miles on it the MDS might not have turned on yet. It sure would be nice if it displays on the evic though.
 

·
Registered
Joined
·
35 Posts
I'm at about 800 miles and I have yet to see any indication of MDS on my EVIC. I did disconnect the battery on my truck to put in the True Flow XDI... It sure would be nice to know when it switches over...
 

·
Registered
Joined
·
95 Posts
The MDS indicator is included on trucks built after November, it was not included on the earlier builds from what I have heard.
 

·
Woosah!!!
Joined
·
421 Posts
I did some searching and looks like it was a hardware and software upgrade in November at one plant and December at the MI plant.
 

·
Registered
Joined
·
108 Posts
I recently test drove 2 2009 Rams. Both said Fuel Saver in the EVIC. MDS seems to work up to 70 mph and then goes off at 71 mph.

Doug
 

·
Woosah!!!
Joined
·
421 Posts
I will have some time on Saturday while the dealer changes out my wheels, and I will go find one that was made in December and drive it. I wish a simple flash of the computer would add this.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #14
Lame, knowing tjat my 2008 charger has it and we got it early last year
 

·
Registered
Joined
·
35 Posts
Sure would be nice to know when the MDS is active. That way, when I want to watch fuel consumption, I could understand how to keep the motor in 4 cylinder mode... OH WELL!
 

·
Registered
Joined
·
269 Posts
My Fuel Saver light only seems to come on when driving under 60 mph. I have never had it come on during normal highway speeds...70mph+. does anybody else see it more often?
 

·
Registered
Joined
·
22 Posts
Mine was built in 9/08 and I don't notice any indication. I can barely feel it engage/disengage at speed ... really have to try to feel it - they did a good job tuning the engine mounts.

Does anyone know if MDS is active at idle? I 'think' it is ... feels like it anyway (some powertrain shake - like cam lope). If it isn't it should be.

I would actually like to see a hand-held tuner be able to bump up MDS cruising speed to 75-80 MPH. I'm a moving speed-bump at 70 MPH or less on MI highways!
 

·
Registered
Joined
·
63 Posts
On my Laramie, you can enable or disable the fuel save indicator, which is the MDS activation notification in the EVIC. There is a setting for it under setup.
 
1 - 20 of 31 Posts
Status
Not open for further replies.
Top