DodgeTalk Forum banner
Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 · (Edited)
I have a 2001 durango with the 4.7. It has started to tick a little at idle and more pronounced under accelration. The OBD gives codes P0206 and P0304, which are cylinder4 misfire, and injector 6 circut malfunction, would this be caused by a bad injector? I have also found that the fuel rail where the injector plugs in on cylinder 4 was wet with gas. I need some help.
 

·
Banned
Joined
·
270 Posts
It could possibly be bad injectors for both #4 and #6. I definitely wouldn't recommend that you drive it anymore until it's fixed. If it's a failed injector or injectors, you'll run the risk of burning your pistons and damaging your engine due to an extreme lean condition.

If you are mechanically inclined, then you should depressurize the fuel system, disconnect the negative battery cable, then remove injector #4 to determine where it is leaking from. My guess is that it's probably leaking at the o-ring gasket connection to the fuel rail.

Then test the resistance across the injector terminals with a multimeter. It should be about 12 ohms if it's good. If it's open or shorted, then the injector needs replacing. Do this for both #4 and #6. You might have to replace both injectors, depending on the results.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
This brings up another question

Will this fix the ticking, and also I checked the ohms today while in the manifold. #6 was at 12.3 and #4 was at 11.7. I did not unhook the battery cable, but it shouldn't have affected my reading due to being disconnected. Thanks so much for youe help.
 

·
Banned
Joined
·
270 Posts
Those test readings look to be okay, but did you check to see if the o-ring gasket was damaged possibly causing the leak at #4? You definitely want to fix the leak for safety reasons. I recommend that you switch injector #4 to #2 and injector #6 to #8. This will show if the injector is the problem should it move to the new location.

The battery needs to be disconnected to 1) clear the trouble code by turning ignition key to ON for at least 20 seconds; and 2) allow you to safely work on the fuel system so that you don't have a spark while working with parts that have gas in it. Safety is important when it comes to doing any work on a vehicle.

The ohm test isn't the gospel to determine an injector that's working perfectly. It determines if it is an electrical problem with the injector, but not a physical problem such as a possible clog that is obstructing fuel flow. This could cause a pressure problem at the injector, causing it to breach a weak o-ring gasket connection to the fuel rail. This is just my analysis, but I could be wrong since it's difficult to diagnose some problems online.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
Well I switched the injectors around, and put all new o rings in. This fixed my ticking sound and also my obd codes. I still have a little bit of a miss in it though. Any idea what this could be. It is more noticable at a hard acceleration but is slightly noticeable at idle. Still running a little rough. Any more ideas?
 

·
WORLD'S GREATEST TRUCK
Joined
·
4,435 Posts
Check your spark plugs, they might need to be replaced.
Or you need to get on it and clear out the carbon build-up after repairing the fuel system. If you floor it and see black smoke, do it a few more times to clean it out.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #8 ·
Well, I changed the spark plugs, and to no avail it still was running rough. I called the dealer and had it diagonsed for 66 dollars. They told me my pcm has went bad and needs to be replaced. They are going to charge me 545 doolars to fix it. I should have it back Friday so i will post back and let you all know how it is running. Thanks alot for the help.

J Rod
 

·
Keystoner
Joined
·
5,534 Posts
ouch. you could get a performance PCM for cheaper.
 

·
Banned
Joined
·
270 Posts
Well, I changed the spark plugs, and to no avail it still was running rough. I called the dealer and had it diagonsed for 66 dollars. They told me my pcm has went bad and needs to be replaced. They are going to charge me 545 doolars to fix it. I should have it back Friday so i will post back and let you all know how it is running. Thanks alot for the help.

J Rod
Good luck, hopefully this fixes it.:tup:
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #11 ·
Welp its been a long two weeks but the durango is running like a top, prolly the best its ran in about a year to year and a half. Picked up the d a the dealer last Wednesday, still running rough like it was missing. Took it back and told them I wasn't happy, 600 for a new pcm and it still runs like crap. They kept it another 2 days and and called me on friday. They said that they thought I had a valve sticking on cylinders 3 and 6, ( i assume because these were the cylinders with the malfunction when I originally took it in). They ran some cleaner through it and it didnt work. It was still missing. So they said they would have to tear it down and send the heads in to get it cleaned, curious I asked what it would cost. He said 700-900 per side not including machine time on the heads. I said forget it iI'll pick it up. There were no codes after the new pcm until i got home from picking it up. Cylinder 4 misfire, so I thought if they think both sides need fixed I'll start there. So i pulled the passenger side valve/cam cover off. Cylinder four was missing the rocker arm on the exaust valve. Still laying on the head, no scratch pinch or scuff. It never hit a thing amazingly. I got it back in and now it runs great. Thank you all for your help. I would have never thought that it threw a rocker arm off though.
 

·
Banned
Joined
·
399 Posts
That is amazing... I can't believe the dealer riped you off like that and could not tell you the real problem...wait, yes I can... I have no trust in shops anymore.. Glad you got it going and no damage was done, well accept the $600 you wasted at stealership...
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top