DodgeTalk Forum banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Hi, Im new to the forum.
I have a 2.7l 2000 dodge intrepid with 94+k miles on it Engine swapped out at 74k for sludge/timing chain Currenlty having confusing problem /Earlier this year march/arpil she would stall for no reason no check engine light no codes nothing , took her to mechanic & they changed cam sensor for month she was fine then started stalling again they changed Crank sensor all was well with the world last week she stalled out again no check engine light or anything driving she stalled out after sitting for a few minutes she started back up as usual only this time got check engine light code was for throttle position sensor Mechanic changed throttle position sensor first day back from shop she was fine.

She started stalling out again just like before would start after a minute or so and go until she was parked and sat for a couple of hours then repeat same process. i have invested alot in this car i wont even horrify people with the cost of engine lol but what could this be now mechanic said put some dry gas its probably bad gas but i dont think so shes stalling on full tank half tank etc i use premium gas, I have in the past 4 months changed water pump, radiator, thermostat, power steering pump, cam & crank some belts etc any ideas what this is ? could the cam & crank sensors go again so soon? Even disconnected the battery to try & reset computer. didnt work


Help me Dodge kanobi's your my only hope****:{ :huh:
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top